opensolaris man page for clrbuf

Query: clrbuf

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

clrbuf(9F)						   Kernel Functions for Drivers 						clrbuf(9F)

NAME
clrbuf - erase the contents of a buffer
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void clrbuf(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buf(9S) structure.
DESCRIPTION
The clrbuf() function zeros a buffer and sets the b_resid member of the buf(9S) structure to 0. Zeros are placed in the buffer starting at bp->b_un.b_addr for a length of bp->b_bcount bytes. b_un.b_addr and b_bcount are members of the buf(9S) data structure.
CONTEXT
The clrbuf() function can be called from user, interrupt, or kernel context.
SEE ALSO
getrbuf(9F), buf(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 clrbuf(9F)
Related Man Pages
bioinit(9f) - sunos
bioinit(9f) - minix
bioinit(9f) - mojave
bioinit(9f) - redhat
bioinit(9f) - linux
Similar Topics in the Unix Linux Community
Trying to block signal
How to learn UNIX
What does this mean?
Solaris 10 - password complexity not working
Shopt -s histappend