opensolaris man page for print

Query: print

OS: opensolaris

Section: 9e

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

print(9E)							Driver Entry Points							 print(9E)

NAME
print - display a driver message on system console
SYNOPSIS
#include <sys/types.h> #include <sys/errno.h> #include <sys/ddi.h> #include <sys/sunddi.h> int prefixprint(dev_t dev, char *str);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). This entry point is required for block devices.
PARAMETERS
dev Device number. str Pointer to a character string describing the problem.
DESCRIPTION
The print() routine is called by the kernel when it has detected an exceptional condition (such as out of space) in the device. To display the message on the console, the driver should use the cmn_err(9F) kernel function. The driver should print the message along with any driver specific information.
RETURN VALUES
The print() routine should return 0 for success, or the appropriate error number. The print routine can fail if the driver implemented a non-standard print() routine that attempted to perform error logging, but was unable to complete the logging for whatever reason.
SEE ALSO
cmn_err(9F) Writing Device Drivers SunOS 5.11 15 Sep 1992 print(9E)
Related Man Pages
getmajor(9f) - opensolaris
print(9e) - opensolaris
getmajor(9f) - bsd
getmajor(9f) - debian
getmajor(9f) - v7
Similar Topics in the Unix Linux Community
need help getting console driver number(index)
cannot print from an application but, i can print from others?
awk print line
print or display certain number of file
Error while trying to print message