Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pckt(7m) [opensolaris man page]

pckt(7M)							  STREAMS Modules							  pckt(7M)

NAME
pckt - STREAMS Packet Mode module SYNOPSIS
int ioctl( fd, I_PUSH, "pckt"); DESCRIPTION
pckt is a STREAMS module that may be used with a pseudo terminal to packetize certain messages. The pckt module should be pushed (see I_PUSH on streamio(7I)) onto the master side of a pseudo terminal. Packetizing is performed by prefixing a message with an M_PROTO message. The original message type is stored in the 1 byte data portion of the M_PROTO message. On the read-side, only the M_PROTO, M_PCPROTO, M_STOP, M_START, M_STOPI, M_STARTI, M_IOCTL, M_DATA, M_FLUSH, and M_READ messages are packetized. All other message types are passed upstream unmodified. Since all unread state information is held in the master's stream head read queue, flushing of this queue is disabled. On the write-side, all messages are sent down unmodified. With this module in place, all reads from the master side of the pseudo terminal should be performed with the getmsg(2) or getpmsg() func- tion. The control part of the message contains the message type. The data part contains the actual data associated with that message type. The onus is on the application to separate the data into its component parts. SEE ALSO
getmsg(2), ioctl(2), ldterm(7M), ptem(7M), streamio(7I), termio(7I) STREAMS Programming Guide SunOS 5.11 3 Jul 1990 pckt(7M)

Check Out this Related Man Page

pckt(7) 						 Miscellaneous Information Manual						   pckt(7)

NAME
pckt - Packet Mode module for STREAMS pty (pseudo-terminal) SYNOPSIS
DESCRIPTION
The feature for STREAMS pty devices allows the user process on the master side of the pty device to be informed of state changes in the pty. To enable in the STREAMS pty device, the user process must push the module onto the master side of the pty with a call to the STREAMS ioctl(2) system call. When the module is pushed onto a STREAMS pty master, certain STREAMS messages going upstream on the master side will get packetized so they can be subsequently retrieved by the master side with a function. When the user process writes data, the module passes the message unchanged downstream on to the next module or driver. When the user process reads data or when the module receives certain STREAMS message types, it constructs a packet out of the message for forwarding upstream. To construct a message packet, the module creates an message. This message contains the original message type in the first data block and the original message in as many data blocks as needed. The user process can then retrieve the message with a call to the func- tion. The module packetizes the following STREAMS message types: All other messages are passed unchanged upstream. If the message is an message, the module looks at the flag and takes the following actions: o If the flag is the module changes it to before creating the message and passing the message upstream. This prevents the stream head's read queue from being flushed by the original o If the flag is the module changes it to before creating the message and passing it upstream. To flush the write queues properly, the module also sends an message with the flag set. o If the flag is the module changes it to before creating the message and passing it upstream. To flush the write queues properly, the module also sends an message with the flag set. AUTHOR
was developed by HP and OSF. SEE ALSO
getmsg(2), ioctl(2), ptm(7), pts(7), ldterm(7), ptem(7), streamio(7). pckt(7)
Man Page