nfslog.conf(4) File Formats nfslog.conf(4)
nfslog.conf - NFS server logging configuration file
The nfslog.conf file specifies the location of the NFS server logs, as well as the loca-
tion of the private work files used by the NFS server and nfslogd(1M) daemon during log-
ging. Each entry in the file consists of a mandatory tag identifier and one or more param-
eter identifiers. The parameter identifier specifies the value or location of the specific
parameter. For instance, the parameter identifier "log=/var/nfs/logs/serverLog" specifies
the location of the NFS server activity log. The mandatory tag identifier serves as an
index into the /etc/nfs/nfslog.conf file to identify the various parameters to be used. At
export time, the share_nfs(1M) command specifies the NFS server logging parameters to use
by associating a tag from the /etc/nfs/nfslog.conf file to the exported file system. It is
legal for more than one file system to be exported using the same logging tag identifier.
NFS server logging is not supported on Solaris machines that are using NFS Version 4.
A "global" tag identifier is included in /etc/nfs/nfslog.conf. It specifies the default
set of values to be used during logging. If no tag identifier is specified at export time,
then the values in the "global" entry are used. The "global" values can be modified by
updating this entry in /etc/nfs/nfslog.conf.
Each entry in the file must contain a mandatory tag identifier and at least one parame-
ter/value pair. If a parameter is not specified in a given entry, the global value of the
parameter will be used. The exact entry syntax follows:
<tag> [defaultdir=<path>] [log=<path><file>] \
[fhtable=<path><file>] [buffer=<path><file>] [logformat=basic|extended]
defaultdir=<path> Specifies the directory where the logging files and working
files will be placed. This path is prepended to all relative
paths specified in other parameters.
log=<path><file> Specifies the location of the user-readable log file. The log
will be located in the defaultdir, unless <path> is an abso-
fhtable=<path><file> Specifies the location of the private file handle to path map-
ping database files. These database files are for the private
use of the NFS server kernel module and the nfslogd daemon.
These files will be located in the defaultdir, unless <path>
is an absolute path. These database files are permanently
stored in the file system. Consult nfslogd(1M) for information
on pruning the database files.
buffer=<path><file> Specifies the location of the private work buffer file used
by the NFS server kernel module to record raw RPC information.
This file is later processed by the nfslog daemon, which in
turn generates the user-readable log file. This work buffer
file will be located in the defaultdir, unless <path> is an
logformat=basic|extended Sets the format of the user-readable log file. If not speci-
fied, the basic format is used. The basic format is compatible
with log files generated by the Washington University FTPd.
The extended format provides a more detailed log, which
includes directory modification operations not included in the
basic format, such as mkdir, rmdir and remove. Note that the
extended format is not compatible with Washington University's
FTPd log format.
Example 1 Using the global Tag
The "global" tag may be modified so that all exported file systems that enabled logging
use a common set of parameters that conform to the specific needs of the user. These val-
ues are used until a specific tag identifier overrides them.
global defaultdir=/var/nfs log=logs/nfslog \
fhtable=tables/fhtable buffer=buffers/nfslog_workbuffer \
Example 2 Overriding the Global defaultdir and logformat
Because log files can become very large, it may be desirable to store the logs and working
files in separate file systems. This can be easily accomplished by simply specifying a
different defaultdir for every file system exported by means of a unique tag:
engineering defaultdir=/engineering/logging \
File systems shared with the engineering identifier will have their logs and workfiles
located in /engineering/logging. For instance, the log file will be located at /engineer-
ing/logging/logs/nfslog. Note that the engineering log file will be stored in the extended
format, while the rest of the log files will remain in the basic format.
Any of the parameters can be updated in a tag identifier, which overrides the global set-
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWnfssr |
nfslogd(1M), share_nfs(1M), attributes(5)
Logs, work files, and file handle to path mapping database can become very large. Be aware
of appropriate placement within the file system name space. See nfslogd(1M)) for informa-
tion on pruning the database files and cycling logs.
SunOS 5.11 2 Dec 2004 nfslog.conf(4)