dhcpsvc.conf(4) File Formats dhcpsvc.conf(4)
dhcpsvc.conf - file containing service configuration parameters for the DHCP service
The dhcpsvc.conf file resides in directory /etc/inet and contains parameters for specify-
ing Dynamic Host Configuration Protocol (DHCP) service configuration settings, including
the type and location of DHCP data store used.
The description of the dhcpsvc.conf file in this man page is informational only. The pre-
ferred method of setting or modifying values within the dhcpsvc.conf file is by using
dhcpconfig(1M) or the dhcpmgr(1M) utility. Do not edit the dhcpsvc.conf file.
The dhcpsvc.conf file format is ASCII; comment lines begin with the crosshatch (#) charac-
ter. Parameters consist of a keyword followed by an equals (=) sign followed by the param-
eter value, of the form:
The following Keyword and Value parameters are supported:
BOOTP_COMPAT String. automatic or manual. Enables support of BOOTP clients.
Default is no BOOTP. Value selects BOOTP address allocation
method. automatic to support all BOOTP clients, manual to sup-
port only registered BOOTP clients. server mode only parame-
CACHE_TIMEOUT Integer. Number of seconds the server caches data from data
store. Used to improve performance. Default is 10 seconds.
server mode only parameter.
CONVER Integer. Container version. Used by DHCP administrative tools
to identify which version of the public module is being used
to administer the data store. CONVER should not be changed
DAEMON_ENABLED TRUE/FALSE. If TRUE, the DHCP daemon can be run. If FALSE,
DHCP daemon process exits immediately if the daemon is
started. Default is TRUE. Generic parameter.
HOSTS_DOMAIN String. Defines name service domain that DHCP administration
tools use when managing the hosts table. Valid only when
HOSTS_RESOURCE is set to nisplus or dns.
HOSTS_RESOURCE String. Defines what name service resource should be used by
the DHCP administration tools when managing the hosts table.
Current valid values are files, nisplus, and dns.
ICMP_VERIFY TRUE/FALSE. Toggles ICMP echo verification of IP addresses.
Default is TRUE. server mode only parameter.
INTERFACES String. Comma-separated list of interface names to listen to.
LOGGING_FACILITY Integer. Local facility number (0-7 inclusive) to log DHCP
events to. Default is not to log transactions. Generic parame-
OFFER_CACHE_TIMEOUT Integer. Number of seconds before OFFER cache timeouts occur.
Default is 10 seconds. server mode only parameter.
OWNER_IP String. List of supplemental ownership addresses that will be
used by the DHCP server in determining the dhcp_network
records that are under its management. Addresses are in the
dotted Internet form of an IPv4 address. Primary value is the
IP address associated with the system's primary interface
(nodename == hostname). Server-mode-only parameter. Note that
using OWNER_IP has some performance impact, thus using a large
number might not be advisable.
PATH Path to DHCP data tables within the data store specified by
the RESOURCE parameter. The value of the PATH keyword is spe-
cific to the RESOURCE.
RELAY_DESTINATIONS String. Comma-separated list of host names and/or IP addresses
of relay destinations. relay mode only parameter.
RELAY_HOPS Integer. Max number of BOOTP relay hops before packet is
dropped. Default is 4. Generic parameter.
RESCAN_INTERVAL Integer. Number of minutes between automatic dhcptab rescans.
Default is not to do rescans. server mode only parameter.
RESOURCE Data store resource used. Use this parameter to name the pub-
lic module. See the PATH keyword in dhcp_modules(5).
RESOURCE_CONFIG String. The private layer provides for module-specific config-
uration information through the use of the RESOURCE_CONFIG
keyword. See dhcp_modules(5).
Providers can access RESOURCE_CONFIG using the configure func-
tion by specifying an optional service provider layer API
int configure(const char *configp);
If this function is defined by the public module provider, it
is called during module load time by the private layer, with
the contents of the RESOURCE_CONFIG string acquired by the
administrative interface (in the case of the dhcpmgr, through
the use of a public module-specific java bean extending the
dhcpmgr to provide a configuration dialog for this informa-
RUN_MODE server or relay. Selects daemon run mode. Default is server.
SECONDARY_SERVER_TIMEOUT Integer. The number of seconds a secondary server waits for a
primary server to respond before responding itself. Default is
20 seconds. This is a server mode only parameter.
UPDATE_TIMEOUT Integer. Number of seconds to wait for a response from the DNS
server before timing out. If this parameter is present, the
DHCP daemon updates DNS on behalf of DHCP clients, and waits
the number of seconds specified for a response before timing
out. You can use UPDATE_TIMEOUT without specifying a number to
enable DNS updates with the default timeout of 15 seconds. If
this parameter is not present, the DHCP daemon does not update
DNS for DHCP clients.
VERBOSE TRUE/FALSE. Toggles verbose mode, determining amount of status
and error messages reported by the daemon. Default is FALSE.
Set to TRUE only for debugging. Generic parameter.
dhcpmgr(1M), in.dhcpd(1M), dhcp(5), dhcp_modules(5)
System Administration Guide: IP Services
SunOS 5.11 26 Jun 2003 dhcpsvc.conf(4)