nisbackup(1M) System Administration Commands nisbackup(1M)
nisbackup - backup NIS+ directories
nisbackup [-v] backup-dir directory...
nisbackup [-v] -a backup-dir
nisbackup backs up a NIS+ directory object on a NIS+ master server. Updates to the NIS+ database will be temporarily disabled while nis-
backup is running. The backup-dir is a UNIX directory that must exist prior to running nisbackup. The nisbackup command can be used to
backup an individual NIS+ directory object or all ( -a) of the NIS+ directory objects served by a master server. The NIS+ directory objects
being backed up will be placed into subdirectories under the backup-dir directory. These subdirectories are named according to the NIS+
directory object they contain. nisbackup operates on individual NIS+ directory objects (for example, org_dir.wiz.com). This allows an
administrator to selectively backup specific directories.
The rpc.nisd(1M) process must be running on the master server with a stable NIS+ database for nisbackup to complete. nisbackup will not
attempt to correct any corruption in the NIS+ database, so it is important that backups be done regularly as part of the NIS+ administra-
The first synopsis is used to backup a single NIS+ directory object or a list of NIS+ directory objects. The objects can be partially qual-
ified or fully qualified. The machine on which the command is executing must be the master for the NIS+ directory objects specified.
The second synopsis will backup all of the NIS+ directory objects that are served by this master. The -a option is the recommended method
of backing up a master server, since it will backup all NIS+ directory objects that are served by this master. If this server is a master
server for more than one domain, the backup will include NIS+ directories that belong to all of the domains served. Individual NIS+ direc-
tory objects can be selected for restoring from a backup-dir created with the -a option. See nisrestore(1M).
The -a option only includes directory objects for which this server is the master. It is possible, but not recommended, to configure a mas-
ter server as a replica for other domains. The objects belonging to those replicated domains will not be backed up with the -a option. The
backup of replicated objects must be run on the master server for those objects.
Do not use the same backup-dir to backup different master servers. Each master server must have its own backup-dir.
nisbackup will set the rpc.nisd(1M) to read only mode, which will disable updates to the NIS+ database. This is neccessary to ensure the
consistency of the backup. For this reason, nisbackup should not be run while large numbers of updates are being applied to the NIS+ data-
base. Update utilities such as nisaddent(1M) should not be run simultaneously with nisbackup.
-a Creates a backup of all NIS+ directory objects for which this server is a master.
-v Verbose option. Additional output will be produced and sent to syslog(3C) upon execution of the command (see syslog.conf(4)).
backup-dir The directory into which the subdirectories containing the backed up objects are placed. This must be created prior to run-
directory The NIS+ directory object(s) being backed up.
Example 1 Backup of the org_dir NIS+ directory object of the domain foo.com on a master server to a directory named /backup
To backup the org_dir NIS+ directory object of the domain foo.com on a master server to a directory named /backup:
master_server# nisbackup /backup org_dir.foo.com.
Example 2 Backup of the entire NIS+ domain foo.com to a directory named /backup
To backup the entire NIS+ domain foo.com to a directory named /backup:
master_server# nisbackup /backup foo.com.
Example 3 Backup of an entire NIS+ database to a backup directory named /backup
To backup an entire NIS+ database to a backup directory named /backup:
master_server# nisbackup -a /backup
0 Successful completion.
1 An error occurred.
This ascii file contains a list of all the objects contained in this backup-dir directory.
A subdirectory that is created in the backup-dir that contains the NIS+ directory-object backup.
A subdirectory that contains the data files that are part of the NIS+ directory-object backup.
This data file contains timestamp information about the directory-object.
A NIS+ data dictionary for all of the objects contained in the NIS+ directory-object backup.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWnisu |
NIS+(1), nisdefaults(1), nisrm(1), nisrestore(1M), rpc.nisd(1M), syslog(3C), nisfiles(4), syslog.conf(4), attributes(5)
NIS+ might not be supported in future releases of the Solaris operating system. Tools to aid the migration from NIS+ to LDAP are available
in the current Solaris release. For more information, visit http://www.sun.com/directory/nisplus/transition.html.
SunOS 5.11 12 Dec 2001 nisbackup(1M)