opensolaris man page for btop

Query: btop

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

btop(9F)						   Kernel Functions for Drivers 						  btop(9F)

NAME
btop - convert size in bytes to size in pages (round down)
SYNOPSIS
#include <sys/ddi.h> unsigned long btop(unsigned long numbytes);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
numbytes Number of bytes.
DESCRIPTION
The btop() function returns the number of memory pages that are contained in the specified number of bytes, with downward rounding in the case that the byte count is not a page multiple. For example, if the page size is 2048, then btop(4096) returns 2, and btop(4097) returns 2 as well. btop(0) returns 0.
RETURN VALUES
The return value is always the number of pages. There are no invalid input values, and therefore no error return values.
CONTEXT
The btop() function can be called from user, interrupt, or kernel context.
SEE ALSO
btopr(9F), ddi_btop(9F), ptob(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 btop(9F)
Related Man Pages
ptob(9f) - sunos
btop(9f) - sunos
ddi_btop(9f) - sunos
btop(9f) - linux
ptob(9f) - linux
Similar Topics in the Unix Linux Community
WebtopProject 0.2.0-RC3 (Default branch)
Webtop software development with LAMP and Prism (video)
WebtopProject 0.5.0-beta (Standalone branch)
WebtopProject 0.5.0-RC1 (Default branch)
WebtopProject 0.5.0-RC1 (Standalone branch)