opendarwin man page for fetch

Query: fetch

OS: opendarwin

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

FETCH(9)						   BSD Kernel Developer's Manual						  FETCH(9)

NAME
fetch, fubyte, fusword, fuswintr, fuword -- fetch data from user-space
SYNOPSIS
#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> #include <sys/resourcevar.h> int fubyte(const void *base); int fusword(void *base); int fuswintr(void *base); long fuword(const void *base);
DESCRIPTION
The fetch functions are designed to copy small amounts of data from user-space. The fetch routines provide the following functionality: fubyte() Fetches a byte of data from the user-space address base. fusword() Fetches a short word of data from the user-space address base. fuswintr() Fetches a short word of data from the user-space address base. This function is safe to call during an interrupt context. fuword() Fetches a word of data from the user-space address base.
RETURN VALUES
The fetch functions return the data fetched or -1 on failure.
SEE ALSO
copy(9), store(9)
BSD
January 7, 1996 BSD
Related Man Pages
fubyte(9) - debian
fuword64(9) - debian
fuibyte(9) - netbsd
fetch(9) - netbsd
fuswintr(9) - netbsd
Similar Topics in the Unix Linux Community
fetchmail imap gmail certificate
How to fetch rows based on line numbers or based on the beginning of a word?
fetch last line no form file which is match with specific pattern by grep command
[Solved] Fetching logs of last few days from logfile
Fetching 1st Column and Last n Columns