NOLOGIN(8) BSD System Manager's Manual NOLOGIN(8)NAME
nologin -- politely refuse a login
The nologin utility displays a message that an account is not available and exits non-zero. It is intended as a replacement shell field for
accounts that have been disabled.
To disable all logins, investigate nologin(5).
SEE ALSO login(1), nologin(5)HISTORY
The nologin utility appeared in 4.4BSD.
BSD June 19, 1993 BSD
Check Out this Related Man Page
NOLOGIN(5) BSD File Formats Manual NOLOGIN(5)NAME
nologin -- file disallowing and containing reason for disallowing logins
The file /etc/nologin, if it exists, causes the login procedure, used by programs such as login(1), to terminate. The program may display
the contents of /etc/nologin to the user before exiting.
This file is a simple mechanism to temporarily prevent incoming logins. As such, the file /etc/nologin is created by shutdown(8) five min-
utes before system shutdown, or immediately if shutdown is in less than five minutes. The file /etc/nologin is removed just before
To disable logins on a per-account basis, see nologin(8).
The file /etc/nologin has no affect on the login procedure for the root user.
/etc/nologin The nologin file resides in /etc.
NO LOGINS: System going down at 18:22
SEE ALSO login(1), ftpd(8), nologin(8), rshd(8), shutdown(8), sshd(8)BSD December 9, 2005 BSD
I'm setting up a Solaris 10 box to run Lawson application, which needs users to have Unix acounts, but the users will not be using interactive shell. To make it more secure, I'd rather not give them a valid shell. I know there's a trick by putting /noshell in the /etc/passwd file, but the problem... (2 Replies)
is the nologin shell available in AIX 5.2? I am familiar with the nologin shell in linux and restricting shell access but still allowing ftp etc. Can this be done in AIX? I have not been able to locate any documentation. Thanks in advance (5 Replies)
Need one clarification..
If suppose, I have disabled the login to a particular user XXX, but not deleted the user.
So the scripts which must be executed using the user XXX can still be executed using that user or is it not possible..?
In our tasks, we are disabling the user XXX, and after... (1 Reply)
Is it possible to SSH with an account that has its shell set to /sbin/nologin?
The reason I ask is because I am running an instance of nagios where I need to use SSH keys to run a check, but I am getting connect errors in Nagios. Also, what is the risk I run into if I just simply change my... (2 Replies)
Trying to figure out the best method of security for oracle user accounts. In Solaris 10 they are set as regular users but have nologin set forcing the dev's to login as themselves and then su to the oracle users.
In Solaris11 we have the option of making it a role because RBAC is enabled but... (1 Reply)
Part of our security audit we found that following system account's had shells configured;
I believe this can be achieved by following commands:
chsh -s /sbin/nologin (user)
usermod -s /sbin/nologin (user)
However, I would like simple script to... (5 Replies)