MKEXTUNPACK(8) BSD System Manager's Manual MKEXTUNPACK(8)NAME
mkextunpack -- extracts the contents of a multikext (mkext) archive
mkextunpack [-v] [-d output_directory] mkext_file
The mkextunpack program list the contents of a multikext file, mkext_file, or unarchives the contents into output_directory (which must
exist). The -v option causes mkextunpack to print the name if each kext as it finds them.
mkextunpack exits with a zero status upon success. Upon failure, it prints an error message and exits with a nonzero status.
SEE ALSO mkextcache(8)BUGS
The mkext file format doesn't record the original filenames of the kexts, so mkextunpack has to guess at what they are. It does this by
using the value of the CFBundleExecutable property of the kext's info dictionary. (Project Builder sets this to the base name of the kext
bundle by default, but the developer can change it.) If that property doesn't exist, the last component of the CFBundleIdentifier is used.
Duplicates have an incrementing index appended to the name. Kexts that have no executable or CFBundleIdentifier are named
``NameUnknown-n.kext'', where n is a number.
Darwin March 29, 2002 Darwin
Check Out this Related Man Page
KEXTSTAT(8) BSD System Manager's Manual KEXTSTAT(8)NAME
kextstat -- display status of loaded kernel extensions (kexts)
kextstat [-a] [-h] [-k] [-l] [-b identifier] ...
The kextstat utility displays the status of any kexts currently loaded in the kernel. The following information is shown for each loaded
Index The load index of the kext (used to track linkage references). Gaps in the list indicate kexts that have been unloaded.
Refs The number of references to this kext by others. If nonzero, the kext cannot be unloaded.
Address The address in kernel space where the kext has been loaded.
Size The number of bytes of kernel memory that the kext occupies. If this is zero, the kext is a built-in part of the kernel that has a
record as a kext for resolving dependencies among kexts.
Wired The number of wired bytes of kernel memory that the kext occupies.
Architecture (if the -a option is used)
The architecture of the kext.
Name The CFBundleIdentifier of the kext.
The CFBundleVersion of the kext.
The index numbers of all other kexts that this kext has a reference to.
These options are available:
Print the architecture of the kext.
-b identifier, -bundle-id identifier
Display the status of only the kext with the given bundle identifier. This option trumps the -no-kernel option; if both are given
and a kernel component is specified, its information is shown.
Print a help message describing each option flag and exit with a success result, regardless of any other options on the command
Don't show information for built-in components of the kernel.
Print the list of loaded kexts only and omit the header (useful for running output through text-analysis tools).
Sort the list by load address.
The kextstat utility exits with a status of 0 on success and with a nonzero status if an error occurs.
SEE ALSO kextcache(8), kextd(8), kextload(8), kextunload(8), kextutil(8)Darwin March 13, 2014 Darwin
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)