|Linux & Unix Commands - Search Man Pages
KEXTSTAT(8) BSD System Manager's Manual KEXTSTAT(8)
kextstat -- display status of dynamically loaded kernel extensions
kextstat [-b kext_bundle_id] [-k] [-l]
The kextstat utility displays the status of any kernel extensions currently loaded in the
kernel. The following information is shown for each loaded kernel extension:
Index The load index of the kernel extension (used to track references). Gaps in the
list indicate kernel extensions that have been unloaded.
Refs The number of references to this extension by others. If nonzero, the extension
cannot be unloaded.
Address The address in kernel space where the extension has been loaded.
Size The number of bytes of kernel memory that the extension occupies. If this is
zero, the extension is actually a built-in part of the kernel that has a record as
an extension for resolving dependencies among extensions.
Wired The number of wired bytes of kernel memory that the extension occupies.
Name The CFBundleIdentifier of the kernel extension.
The CFBundleVersion of the kernel extension.
The index numbers of all other kernel extensions that this extension has a refer-
The following options are available:
Display the status of only the kernel extension with the given bundle identifier.
This option trumps the -k option; if both are given and a kernel component is
specified, its information is shown.
-k Don't show information for built-in components of the kernel.
-l Print the list of loaded kexts only and omit the header (useful for running output
through text-analysis tools).
The kextstat utility exits with a status of 0 on success and with a nonzero status if an
kextcache(8), kextd(8), kextload(8), kextunload(8)
The kextstat command is based on the command kldstat written by Doug Rabson
Darwin April 17, 2002 Darwin
All times are GMT -4. The time now is 02:46 AM.