CORE(5) BSD File Formats Manual CORE(5)NAME
core -- memory image file format
SYNOPSIS
#include <sys/param.h>
DESCRIPTION
A small number of signals which cause abnormal termination of a process also cause a record of the process's in-core state to be written to
disk for later examination by one of the available debuggers. (See sigaction(2).) This memory image is written to a file named by default
core.pid in the /cores directory; provided the terminated process had write permission in the directory, and the directory existed.
The maximum size of a core file is limited by setrlimit(2). Files which would be larger than the limit are not created.
The core file consists of the ~ Mach-O(5) header as described in the <mach-o/loader.h> file. The remainder of the core file consists of
various sections described in the Mach-O(5) header.
NOTE
Core dumps are disabled by default under Darwin/Mac OS X. To re-enable core dumps, a privlaged user must edit /etc/hostconfig to contain the
line:
COREDUMPS=-YES-
SEE ALSO gdb(1), setrlimit(2), sigaction(2), Mach-O(5), sysctl(8)HISTORY
A core file format appeared in Version 6 AT&T UNIX.
BSD March 18, 2002 BSD
Check Out this Related Man Page
GCORE(1) General Commands Manual GCORE(1)NAME
gcore - get core image of running process
SYNOPSIS
gcore [-s][-c core] pid
DESCRIPTION
gcore creates a core image of each specified process, suitable for use with adb(1). By default the core image is written to the file
<pid>.core.
The options are:
-c Write the core file to the specified file instead of <pid>.core.
-s Stop the process while creating the core image and resume it when done. This makes sure that the core dump will be in a consistent
state. The process is resumed even if it was already stopped. Of course, you can obtain the same result by manually stopping the
process with kill(1).
The core image name was changed from core.<pid> to <pid>.core to prevent matching names like core.h and core.c when using programs such as
find(1).
FILES
<process-id>.core The core image.
BUGS
If gcore encounters an error while creating the core image and the -s option was used the process will remain stopped.
Swapped out processes and system processes (the swapper) may not be gcore'd.
4.2 Berkeley Distribution April 15, 1994 GCORE(1)
Hi ALL,
Is it possible to decode the core dumb file to find the error?
I get an Memory Core Dumb error with an core file.
Regards,
P. Prathaban. (3 Replies)
Hi,
Is there any way to find the mode of the binary file (debug or release) by analyzing the core file generated by that binary on the HPUX11i Platform? (5 Replies)
Ok, I have what I think is a relatively simple question, but being me I'll give the full background. In writing a new CheckSystem for one of my servers at work I want to check for core dumps. I was originally doing this like so:
dumps=`ls -ltr /dvs/dncs/tmp/corefiles/|awk '{print $9}'|egrep... (5 Replies)
Hello all.
I have made an application in C using pthreads. My problem is that my program seems to be only using 1 of my cores when I create multiple threads. I have 4 cores (Q9300). I am using Ubuntu 8.04.
I do believe the problem is that on linkage it's using a pthread emulation package... (4 Replies)
My program is not dumping core when hitting a segmentation violation inside a thread.
However, it dumps core when the segv occurs within main.
Any ideas on how to diagnose this?
AIX 5.3 (4 Replies)
Hi All ,
i found two core files on aix customer machine due to two pro-c executables . we dont have any debugger like dbx . even i captured the log reports reg the core dumps .. i pasted the details here belo3w .please help me out h ow to resolve the issue :-( .... THANKS IN ADVANCE ...
... (4 Replies)
Hello All,
I need to basically capture any core dump of C++ binary which is running in a perl script on SUN Solaris OS.
I dont kno much in C++. Can you please suggest me a C++ binary that core dumps when i run which i can use to capture in my Perl script.
Thanks,
Sateesh (3 Replies)
Hi,
I am running a iplanet webserver in a HP-UX box and the iplanet webserver is crashing oftenly. I want to take a core dump. Could you please let me know how can i check whether server core is enabled?
if not how can i enable the same?
Also let me know to which path it saves the core.
... (7 Replies)
I have a weird situation in which the binary dumps core and gives bus error. But before dumping the core and throwing the buss error, it gives some output.
unfortunately I can't grep the output before core dump
db2bfd -b test.bnd
maxSect 15
Bus Error (core dumped)
But if I do ... (4 Replies)
hello everyone,
can anyone tell me what drivers the Mach kernel works with. I'm thinking about experimenting with the Mach kernel, and yes I know there are other kernels that are easier to work with but I just want to use the Mach kernel. So with that being said, can the Mach kernel work with... (11 Replies)
1. The problem statement, all variables and given/known data:
When looking for corefiles, include any file with core in its name. (Some UNIX/Linux systems add the PID of the process that created the core to reduce the chances of overwriting an already existing core file that might be needed. The... (6 Replies)
In sun solaris whenever a jvm crashes we used to get the core file generated in binary format. We convert this core file to human readable format using
pstack corefile >> log
How can we convert the core file generated in HPUX to human readable format ? We dont have pstack either. (11 Replies)
Yesterday someone asked me to install TeamViewer and share my Mac screen with them while on a conference call.
I shut down my Mac before sleeping and woke up to some major problem with my 12-core CPU in hyperdrive, and the system activity monitor showed my Mac kernel_task was at 1,200% and the... (30 Replies)
Hi,
Currently, we have a Perl script from a third-party vendor that is generating core dumps. It has been reported. We can't turn off the script as it does generate some diagnostic file that's required. So at the moment, we have to let it continue to do its run.
I wish I can say the vendor is... (8 Replies)