|Linux & Unix Commands - Search Man Pages
LO(4) BSD Kernel Interfaces Manual LO(4)
lo -- software loopback network interface
The loop interface is a software loopback mechanism which may be used for performance analy-
sis, software testing, and/or local communication. As with other network interfaces, the
loopback interface must have network addresses assigned for each address family with which
it is to be used. These addresses may be set or changed with the SIOCSIFADDR ioctl(2). The
loopback interface should be the last interface configured, as protocols may use the order
of configuration as an indication of priority. The loopback should never be configured
first unless no hardware interfaces exist.
lo%d: can't handle af%d. The interface was handed a message with addresses formatted in an
unsuitable address family; the packet was dropped.
intro(4), inet(4), ns(4)
The lo device appeared in 4.2BSD.
Previous versions of the system enabled the loopback interface automatically, using a non-
standard Internet address (127.1). Use of that address is now discouraged; a reserved host
address for the local network should be used instead.
4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution
All times are GMT -4. The time now is 11:39 PM.