netbsd man page for yield

Query: yield

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PREEMPT(9)						   BSD Kernel Developer's Manual						PREEMPT(9)

NAME
preempt, yield -- general preempt and yield functions
SYNOPSIS
#include <sys/sched.h> void preempt(void); #include <sys/proc.h> void yield(void);
DESCRIPTION
The preempt() function puts the current LWP back on the system run queue and performs an involuntary context switch. The yield() function is mostly same as preempt(), except that it performs a voluntary context switch. These functions drop the kernel lock before switching and re-acquire it before returning.
BSD
July 3, 2007 BSD
Related Man Pages
critical_exit(9) - freebsd
critical(9) - debian
critical(9) - freebsd
critical(9) - mojave
critical_enter(9) - mojave
Similar Topics in the Unix Linux Community
Yield Prolog: 1.0.3 Released
Puzzle: file name grepped from text file yields &quot;no such file&quot;
exec perl in expect script yields &quot;invalid command&quot;
UNIX.com links from Google yield invalid thread error
Cp via NFS vs. scp yields unexpected difference