VFSSUBR(9) BSD Kernel Developer's Manual VFSSUBR(9)
vfssubr, vfs_getnewfsid, vfs_getvfs, vfs_export, vfs_showexport, vfs_export_lookup,
vfs_setpublicfs, vfs_mountedon, vfs_mountroot, vfs_unmountall, vfs_busy, vfs_unbusy,
vfs_mountalloc, vfs_rootmountalloc, vfs_shutdown, vfs_attach, vfs_detach, vfs_reinit,
vfs_getopsbyname, vfs_suspend, vfs_resume -- high-level interface to kernel file system
vfs_getnewfsid(struct mount *mp);
struct mount *
vfs_export_lookup(struct mount *mp, struct netexport *nep, struct export_args *argp);
vfs_setpublicfs(struct mount *mp, struct netexport *nep, struct export_args *argp);
vfs_mountedon(struct vnode *vp);
vfs_unmountall(struct lwp *l);
vfs_busy(struct mount *mp, int flags, struct simplelock *interlkp);
vfs_unbusy(struct mount *mp);
struct mount *
vfs_mountalloc(struct vfsops *vfs, struct vnode *vp);
vfs_rootmountalloc(char *fstypename, char *devname, struct mount **mpp);
vfs_attach(struct vfsops *vfs);
vfs_detach(struct vfsops *vfs);
struct vfsops *
vfs_getopsbyname(const char *name);
vfs_suspend(struct mount *mp, int nowait);
vfs_resume(struct mount *mp);
The high-level functions described in this page are the interface to the kernel file system
Get a new unique file system id type for the file system specified by the mount
structure mp. The file system id type is stored in mp->mnt_stat.f_fsidx.
Lookup a mount point with the file system identifier fsid.
vfs_export_lookup(mp, nep, argp)
Check client permission on the exportable file system specified by the mount struc-
ture mp. The argument nam is the address of the networked client. This function
is used by file system type specific functions to verify that the client can access
the file system.
vfs_setpublicfs(mp, nep, argp)
Set the publicly exported file system specified by the mount structure mp.
Check to see if a file system is mounted on a block device specified by the vnode
Mount the root file system.
Unmount all file systems.
vfs_busy(mp, flags, interlkp)
Mark the mount point specified by mp as busy. This function is used to synchronize
access and to delay unmounting. The interlock specified by argument interlkp is
not released on failure.
Free the busy file system specified by the mount structure mp.
Allocate and initialise a mount structure, setting mnt_vnodecovered to vp and
mnt_op to vfsops. On success, mark the mount structure as busy and return its
address. Otherwise, return NULL.
vfs_rootmountalloc(fstypename, devname, mpp)
Lookup a file system type specified by the name fstypename and if found allocate
and initialise a mount structure for it. The allocated mount structure is returned
in the address specified by mpp. The device the root file system was mounted from
is specified by the argument devname and is recorded in the new mount structure.
Sync and unmount all file systems before shutting down. Invoked by cpu_reboot(9).
Establish file system vfs and initialise it.
Remove file system vfs from the kernel.
Reinitialises all file systems within the kernel through file system-specific vfs
operation (see vfsops(9)).
Given a file system name specified by name, look up the vfs operations for that
file system (see vfsops(9)), or return NULL if file system isn't present in the
Request a mounted file system to suspend all operations. All new operations to the
file system are stopped. After all operations in progress have completed, the file
system is synced to disk and the function returns. If a file system suspension is
currently in progress and nowait is set EWOULDBLOCK is returned. If the operation
is successful, zero is returned, otherwise an appropriate error code is returned.
Request a mounted file system to resume operations.
The vfs interface functions are implemented within the files sys/kern/vfs_subr.c and
intro(9), namei(9), vfs(9), vfsops(9), vnode(9), vnodeops(9)
BSD May 9, 2009 BSD