STORE(9) BSD Kernel Developer's Manual STORE(9)NAME
store, subyte, suibyte, susword, suswintr, suword, suiword -- store data to user-space
SYNOPSIS
#include <sys/types.h>
#include <sys/systm.h>
int
subyte(void *base, int c);
int
susword(void *base, short c);
int
suswintr(void *base, short c);
int
suword(void *base, long c);
DESCRIPTION
The store functions are designed to copy small amounts of data to the user-space of the currently running process.
The store routines provide the following functionality:
subyte() Stores a byte of data to the user-space address base.
susword() Stores a short word of data to the user-space address base.
suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context.
suword() Stores a word of data to the user-space address base.
RETURN VALUES
The store functions return 0 on success or -1 on failure.
SEE ALSO copy(9), fetch(9)BSD January 7, 1996 BSD
Check Out this Related Man Page
STORE(9) BSD Kernel Developer's Manual STORE(9)NAME
store, subyte, suswintr, suword -- store data to user-space
SYNOPSIS
#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>
int
subyte(void *base, int byte);
int
suword(void *base, long word);
int
suword16(void *base, int word);
int
suword32(void *base, int32_t word);
int
suword64(void *base, int64_t word);
#include <sys/resourcevar.h>
int
suswintr(void *base, int word);
DESCRIPTION
The store functions are designed to copy small amounts of data to user-space.
The store routines provide the following functionality:
subyte() Stores a byte of data to the user-space address base.
suword() Stores a word of data to the user-space address base.
suword16() Stores 16 bits of of data to the user-space address base.
suword32() Stores 32 bits of of data to the user-space address base.
suword64() Stores 64 bits of of data to the user-space address base.
suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context.
RETURN VALUES
The store functions return 0 on success or -1 on failure.
SEE ALSO copy(9), fetch(9)BSD October 5, 2009 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)