STORE(9) BSD Kernel Developer's Manual STORE(9)NAME
store, subyte, suibyte, susword, suswintr, suword, suiword -- store data to user-space
SYNOPSIS
#include <sys/types.h>
#include <sys/systm.h>
int
subyte(void *base, int c);
int
susword(void *base, short c);
int
suswintr(void *base, short c);
int
suword(void *base, long c);
DESCRIPTION
The store functions are designed to copy small amounts of data to the user-space of the currently running process.
The store routines provide the following functionality:
subyte() Stores a byte of data to the user-space address base.
susword() Stores a short word of data to the user-space address base.
suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context.
suword() Stores a word of data to the user-space address base.
RETURN VALUES
The store functions return 0 on success or -1 on failure.
SEE ALSO copy(9), fetch(9)BSD January 7, 1996 BSD
Check Out this Related Man Page
STORE(9) BSD Kernel Developer's Manual STORE(9)NAME
store, subyte, suswintr, suword -- store data to user-space
SYNOPSIS
#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>
int
subyte(void *base, int byte);
int
suword(void *base, long word);
int
suword16(void *base, int word);
int
suword32(void *base, int32_t word);
int
suword64(void *base, int64_t word);
#include <sys/resourcevar.h>
int
suswintr(void *base, int word);
DESCRIPTION
The store functions are designed to copy small amounts of data to user-space.
The store routines provide the following functionality:
subyte() Stores a byte of data to the user-space address base.
suword() Stores a word of data to the user-space address base.
suword16() Stores 16 bits of of data to the user-space address base.
suword32() Stores 32 bits of of data to the user-space address base.
suword64() Stores 64 bits of of data to the user-space address base.
suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context.
RETURN VALUES
The store functions return 0 on success or -1 on failure.
SEE ALSO copy(9), fetch(9)BSD October 5, 2009 BSD
Dear All ;
first how are you every body I'm just subscribed in your forum and i hope i found what i searched for along time .
I'm not a Solaris specialist but i read more to build a Network Management Station depends on Solaris as OS and it is working good now .
my problem is how to perform... (16 Replies)
Hi I'm new to Linux, and I'm trying to write a shell script where I remove a specific file (i.e file1 or file1.txt), but i don't actually remove it, i move it to a directory called 'trash' - in vi I created a file with the path /usr/bin/del and in it I have:
mv $file /home/trash, but I'm getting... (24 Replies)
Hi!
I strated to script since 1 month and I don't have much expirience but this thing here is strange
I have a script where I want to store a svn command in a var to check it later
so it's like this
#!/bin/sh
list=`ssh itadmin@192.168.1.200 "ls /home/svn"` # this stores the list of... (13 Replies)
Hello All,
I backed up my RHEL 4 as an image.
Then I restored the image (by mondorestore) on my machine. Everything went fine but I dont get the normal boot sequence as it used to come when I freshly installed RHEL4.
The messages that are shown when the system boots are something like-
"... (13 Replies)
Hi all,
I am working on a backup based script, in which it enters to a directory and check the sub-directories and copy the names into an array.
cd $CPFs
k=0
for i in *
do
if
then
ARRs="$i"
k=$(($k+1))
#echo "$i"
... (19 Replies)
Hello all,
I am trying to run stored procrdure from shell script which takes one argument. And also I want to verify in the script whether the script executed successfully. However the Stored procedure is not running from shell script. Manually if I run it update the data in the table.
Can... (29 Replies)
Hi,
First sorry for my english !
I'm a newbie on Solaris and I'm trying to clone a SUN T5220 (sun4V platform) on SUN V240 (sun4u platform) using ufsdump/ufsrestore.
Dumping all filesystem and restoring it on the V240 box and Make the disk bootable using installboot command.
When... (21 Replies)
I am reading a value from a file and want to store the value in a dynamic array as i don't know the number of occurrences of the value in that file.
How can i do that and then later fetch that value from array (25 Replies)
Hey guys I am new at Solaris 10, and I'm having a open error on
/dev/dsk/c1t1d0s6, when booting.
We have a Sunfire v240 running Solaris 10, which is connected to a Storedge 3320, via SCSI.
Any help, is appreciated (14 Replies)
Hi,
I am an newbie to AIX.
Recently, I being assigned to do an mksysb restoration at our DR site.
It always encounter "Out of Space" during restoration, this is even when I restored to 4x146GB HDD.
Even though, on production, it only need 2x146GB HDD for the rootvg.
What is the problem, I... (19 Replies)
Good Afternoon,
I'm going to attempt a ufsrestore of a Solaris 9 machine from a connected NAS containing the ufsdumps. The idea is to be able to take ufsdumps of a failed machine (machine 1), and use them to set up a backup machine (machine 2). (I'm testing for disaster recovery)
Note... (52 Replies)
Good Afternoon,
I'm setting up a SunBlade 2500 using ufsrestoreand have gotten to the point where I have restored the root and usr partitions. However, the machine keeps rebooting, never really coming up. Looking at vfstab, it looks pretty empty- shouldn't I see entries like... (22 Replies)
I have a .dmg file which was created from a disk consisting of two partitions. When I mount the dmg both partitions pop up, so I know the imaging worked properly. One partition is HFS+ and the other is FAT32.
So far, I've been unable to find a way to restore the dmg to a flash drive where both... (17 Replies)
I want to store the passwords in a global file, so that all the users will not use them to login but a process should use it. One way is to keep the passwords in a .ini file and execute the file in the start of the script and use that variable.
But with this, one can echo the variable in the... (15 Replies)