Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

simple_lock(9) [netbsd man page]

LOCK(9) 						   BSD Kernel Developer's Manual						   LOCK(9)

NAME
lock, simple_lock_init, simple_lock, simple_lock_try, simple_unlock, simple_lock_freecheck, simple_lock_dump, lockinit, lockmgr, lockstatus, lockmgr_printinfo, spinlockinit, spinlockmgr -- kernel lock functions DESCRIPTION
These interfaces have been obsoleted and removed from the system. Please see the condvar(9), mutex(9), and rwlock(9) manual pages for information on kernel synchronisation primitives. SEE ALSO
condvar(9), mutex(9), rwlock(9) HISTORY
The kernel locking API first appeared in 4.4BSD-lite2, and was replaced in NetBSD 5.0. BSD
January 30, 2008 BSD

Check Out this Related Man Page

simple_lock_try(9r)													       simple_lock_try(9r)

NAME
simple_lock_try - General: Tries to assert a simple lock SYNOPSIS
#include <kern/lock.h> boolean_t simple_lock_try( simple_lock_t slock_ptr ); ARGUMENTS
Specifies a pointer to a simple lock structure. You can declare this simple lock structure by using the decl_simple_lock_data routine. DESCRIPTION
The simple_lock_try routine tries to assert a lock with read and write access for the resource associated with the specified simple lock. The main difference between this routine and simple_lock is that simple_lock_try returns immediately if the resource is already locked, while simple_lock spins until the lock has been obtained. Thus, call simple_lock_try when you need a simple lock but the code cannot spin until the lock is obtained. To release a simple lock successfully asserted by simple_lock_try, call the simple_unlock routine. RETURN VALUES
The simple_lock_try routine returns one of the following values: The simple_lock_try routine successfully asserted the simple lock. The simple_lock_try routine failed to assert the simple lock. FILES
SEE ALSO
Routines: decl_simple_lock_data(9r), simple_lock(9r), simple_lock_init(9r), simple_lock_terminate(9r), simple_unlock(9r) Data Structures: slock(9s) simple_lock_try(9r)
Man Page