netbsd man page for setjmp

Query: setjmp

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

SETJMP(9)						   BSD Kernel Developer's Manual						 SETJMP(9)

NAME
setjmp, longjmp -- non-local jumps
SYNOPSIS
#include <machine/types.h> #include <sys/systm.h> int setjmp(label_t *label); void longjmp(label_t *label);
DESCRIPTION
The setjmp() function saves its calling environment in label. It returns zero on success. The longjmp() function restores the environment saved by the most recent invocation of setjmp(). It returns so that kernel execution continues as if the corresponding invocation of the setjmp() had just returned. setjmp() and longjmp() are a machine-independent interface for machine-dependent implementations. These functions are primarily used by ddb(4).
SEE ALSO
ddb(4)
BSD
May 23, 2002 BSD
Related Man Pages
_setjmp(3) - mojave
longjmp(3) - mojave
longjmperror(3) - mojave
_longjmp(3) - osx
longjmperror(3) - osx
Similar Topics in the Unix Linux Community
signal() and sigsetjmp()