Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

scanc(9) [netbsd man page]

SCANC(9)						   BSD Kernel Developer's Manual						  SCANC(9)

NAME
scanc -- use byte string as lookup table index SYNOPSIS
#include <lib/libkern/libkern.h> int scanc(size_t size, const u_char *cp, const u_char table[], int mask); DESCRIPTION
The scanc() function scans the byte string cp, whose length is size. A character in the string is used as an index in the 256-byte table. If a bitwise-AND of the byte from the table and mask isn't zero or the string is exhausted, the scan stops. RETURN VALUES
The scanc() function returns the number of characters skipped. HISTORY
The scanc() function emulates a VAX instruction with the same name. BSD
November 1, 2011 BSD

Check Out this Related Man Page

BM(3)							   BSD Library Functions Manual 						     BM(3)

NAME
bm_comp, bm_exec, bm_free -- Boyer-Moore string search LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <sys/types.h> #include <bm.h> bm_pat * bm_comp(u_char *pattern, size_t patlen, u_char freq[256]); u_char * bm_exec(bm_pat *pdesc, u_char *text, size_t len); void bm_free(bm_pat *pdesc); DESCRIPTION
These routines implement an efficient mechanism to find an occurrence of a byte string within another byte string. bm_comp() evaluates the patlen bytes starting at pattern, and returns a pointer to a structure describing them. The bytes referenced by pattern may be of any value. The search takes advantage of the frequency distribution of the bytes in the text to be searched. If specified, freq should be an array of 256 values, with higher values indicating that the corresponding character occurs more frequently. (A less than optimal frequency distribu- tion can only result in less than optimal performance, not incorrect results.) If freq is NULL, a system default table is used. bm_exec() returns a pointer to the leftmost occurrence of the string given to bm_comp() within text, or NULL if none occurs. The number of bytes in text must be specified by len. Space allocated for the returned description is discarded by calling bm_free() with the returned description as an argument. The asymptotic speed of bm_exec() is O(len/patlen). SEE ALSO
regexp(3), strstr(3) Hume and Sunday, "Fast String Searching", Software Practice and Experience, Vol. 21, 11, pp. 1221-48, November 1991. BSD
April 8, 2001 BSD
Man Page