ROUNDUP(9) BSD Kernel Developer's Manual ROUNDUP(9)NAME
roundup -- macros for counting and rounding
SYNOPSIS
#include <sys/param.h>
size
howmany(x, size);
size
roundup(x, size);
size
rounddown(x, size);
size
roundup2(x, size);
int
powerof2(x);
DESCRIPTION
The roundup() and rounddown() macros return an integer from rounding x up and down, respectively, to the next size. The howmany() macro in
turn reveals how many times size fits into x, rounding the residual up.
The roundup2() macro also rounds up, but with the assumption that size is a power of two. If x is indeed a power of two, powerof2() return
1.
RETURN VALUES
The return value is an integer from the respective operation. If x is 0, all macros except powerof2() return 0. The behavior is undefined
if size is 0.
EXAMPLES
The following example rounds the variable rx to a 32-bit boundary:
uint16_t rx;
...
rx = roundup2(rx, sizeof(uint32_t));
SEE ALSO ilog2(3), param(3), imax(9)CAVEATS
All described macros make no assumptions about the type of the parameters. These are implicitly assumed to be unsigned integers.
BSD June 1, 2011 BSD
Check Out this Related Man Page
ROUNDUP(9) BSD Kernel Developer's Manual ROUNDUP(9)NAME
roundup -- macros for counting and rounding
SYNOPSIS
#include <sys/param.h>
size
howmany(x, size);
size
roundup(x, size);
size
rounddown(x, size);
size
roundup2(x, size);
int
powerof2(x);
DESCRIPTION
The roundup() and rounddown() macros return an integer from rounding x up and down, respectively, to the next size. The howmany() macro in
turn reveals how many times size fits into x, rounding the residual up.
The roundup2() macro also rounds up, but with the assumption that size is a power of two. If x is indeed a power of two, powerof2() return
1.
RETURN VALUES
The return value is an integer from the respective operation. If x is 0, all macros except powerof2() return 0. The behavior is undefined
if size is 0.
EXAMPLES
The following example rounds the variable rx to a 32-bit boundary:
uint16_t rx;
...
rx = roundup2(rx, sizeof(uint32_t));
SEE ALSO ilog2(3), param(3), imax(9)CAVEATS
All described macros make no assumptions about the type of the parameters. These are implicitly assumed to be unsigned integers.
BSD June 1, 2011 BSD
Hi All,
We have the commands top and ps through which we can find out the size of the running process.
These commnds are giving the size of my process in MB after rounding of the size.
Is there any way by which I can get the size of my process in Bytes or KBytes.
Any help would be greatly... (2 Replies)
After rcp -rp from remote host, using du -k to verify the file size but total file size have different size. Check on individual file, file size is correct.
How can I confirm on the file size after ftp?
Pls advise.
Thank you. (15 Replies)
Hello experts,
I do -
$ ls -lhtr logs2007*
Is it possible that i can get the results of-
totals size in MB/KB for ALL "logs2007*"
note: in the same directory I have "logs2006*" & "logs2007*" files. (4 Replies)
Hi
i increased the lv size using smit hacmp.
but, the new size is not reflecting.. why?.
the pp size is 512 MB. before it was 4 PP's. i increased to 10 PP's.
when i type df -m /xxx.. it is showing 2GB only.
see the info below..
root@db:/ > df -m /xxx/xxx
Filesystem MB blocks Free... (2 Replies)