Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

rounddown(9) [netbsd man page]

ROUNDUP(9)						   BSD Kernel Developer's Manual						ROUNDUP(9)

NAME
roundup -- macros for counting and rounding SYNOPSIS
#include <sys/param.h> size howmany(x, size); size roundup(x, size); size rounddown(x, size); size roundup2(x, size); int powerof2(x); DESCRIPTION
The roundup() and rounddown() macros return an integer from rounding x up and down, respectively, to the next size. The howmany() macro in turn reveals how many times size fits into x, rounding the residual up. The roundup2() macro also rounds up, but with the assumption that size is a power of two. If x is indeed a power of two, powerof2() return 1. RETURN VALUES
The return value is an integer from the respective operation. If x is 0, all macros except powerof2() return 0. The behavior is undefined if size is 0. EXAMPLES
The following example rounds the variable rx to a 32-bit boundary: uint16_t rx; ... rx = roundup2(rx, sizeof(uint32_t)); SEE ALSO
ilog2(3), param(3), imax(9) CAVEATS
All described macros make no assumptions about the type of the parameters. These are implicitly assumed to be unsigned integers. BSD
June 1, 2011 BSD

Check Out this Related Man Page

ROUNDUP-CTL(1)						      General Commands Manual						    ROUNDUP-CTL(1)

NAME
roundup-ctl - roundup server control interface SYNOPSIS
roundup-ctl [options] command DESCRIPTION
roundup-ctl is a front end to the roundup server. It is designed to help the administrator control the functioning of the roundup server daemon. This script mimics most of the behaviour of a regular init script, but works as a front end to the runit package to control the roundup service. So, in order to use this, you need the runit package, too. Please note that using this script is mostly incompatible with having roundup controlled by runit directly in the form of automatic startup. The roundup-ctl script returns a 0 exit value on success, and >0 if an error occurs. For more details, view the comments in the script. OPTIONS
-d directory Use given directory as service directory. COMMANDS
The command can be any one or more of the following options: start If the roundup server is not runinng, start it. If the server stops, restart it. stop Stops the roundup server. status Print sta- tus of the roundup server. SEE ALSO
roundup-server(1) runsvctrl(8) runsvstat(8) svwaitdown(8) AUTHOR
Bastian Kleineidam <calvin@debian.org>, Toni Mueller <toni@debian.org> 31 May 2004 ROUNDUP-CTL(1)
Man Page

4 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

How to get the size of process in Bytes

Hi All, We have the commands top and ps through which we can find out the size of the running process. These commnds are giving the size of my process in MB after rounding of the size. Is there any way by which I can get the size of my process in Bytes or KBytes. Any help would be greatly... (2 Replies)
Discussion started by: darshi
2 Replies

2. UNIX for Advanced & Expert Users

du -k shows different size in two nodes

After rcp -rp from remote host, using du -k to verify the file size but total file size have different size. Check on individual file, file size is correct. How can I confirm on the file size after ftp? Pls advise. Thank you. (15 Replies)
Discussion started by: KhawHL
15 Replies

3. Solaris

file size counts??

Hello experts, I do - $ ls -lhtr logs2007* Is it possible that i can get the results of- totals size in MB/KB for ALL "logs2007*" note: in the same directory I have "logs2006*" & "logs2007*" files. (4 Replies)
Discussion started by: thepurple
4 Replies

4. AIX

HACMP LV size is not reflecting

Hi i increased the lv size using smit hacmp. but, the new size is not reflecting.. why?. the pp size is 512 MB. before it was 4 PP's. i increased to 10 PP's. when i type df -m /xxx.. it is showing 2GB only. see the info below.. root@db:/ > df -m /xxx/xxx Filesystem MB blocks Free... (2 Replies)
Discussion started by: honeym210
2 Replies