|Linux & Unix Commands - Search Man Pages
GETIOBUF(9) BSD Kernel Developer's Manual GETIOBUF(9)
getiobuf, putiobuf -- I/O descriptor allocation interface
struct buf *
getiobuf(struct vnode *vp, bool waitok);
putiobuf(struct buf *bp);
getiobuf() allocates a buf structure.
vp The vnode to which the allocated buffer will be associated. This can be NULL.
waitok If true, getiobuf can sleep until enough memory is available. Otherwise, it returns
NULL immediately if not enough memory is available.
Note that the allocated buffer doesn't belong to the buffer cache. To free it, putiobuf()
should be used. brelse() should not be used on it.
putiobuf() frees bp, which should be a buffer allocated with getiobuf().
BSD May 6, 2008 BSD
All times are GMT -4. The time now is 04:05 PM.