Query: preempt
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
PREEMPT(9) BSD Kernel Developer's Manual PREEMPT(9)NAMEpreempt, yield -- general preempt and yield functionsSYNOPSIS#include <sys/sched.h> void preempt(void); #include <sys/proc.h> void yield(void);DESCRIPTIONThe preempt() function puts the current LWP back on the system run queue and performs an involuntary context switch. The yield() function is mostly same as preempt(), except that it performs a voluntary context switch. These functions drop the kernel lock before switching and re-acquire it before returning.BSDJuly 3, 2007 BSD
Related Man Pages |
---|
critical(9) - debian |
csf(9) - netbsd |
mi_switch(9) - netbsd |
critical(9) - mojave |
critical_enter(9) - mojave |
Similar Topics in the Unix Linux Community |
---|
Effect of Preemptive Kernel |
Blocked process and preempt |
Can someone describe the process of pre-emption in UNIX? |