Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ppsratecheck(9) [netbsd man page]

PPSRATECHECK(9) 					   BSD Kernel Developer's Manual					   PPSRATECHECK(9)

NAME
ppsratecheck -- function to help implement rate-limited actions SYNOPSIS
#include <sys/time.h> int ppsratecheck(struct timeval *lasttime, int *curpps, int maxpps); DESCRIPTION
The ppsratecheck() function provides easy way to perform packet-per-sec, or event-per-sec, rate limitation. The motivation for implementing ppsratecheck() was to provide a mechanism that could be used to add rate limitation to network packet output. For certain network packets, we may want to impose rate limitation, to avoid denial-of-service attack possibilities. maxpps specifies maximum permitted packets, or events, per second. If ppsratecheck() is called more than maxpps times in a given one second period, the function will return 0, indicating that we exceeded the limit. If we are below the limit, the function will return 1. If maxpps is set to 0, the function will always return 0 (no packets/events are permitted). Negative maxpps indicates that rate limitation is dis- abled, and ppsratecheck will always return 1. curpps and lasttime are used to maintain the number of recent calls. curpps will be incremented every time ppsratecheck() is called, and will be reset whenever necessary. SEE ALSO
log(9), printf(9), ratecheck(9), time_second(9) HISTORY
The ppsratecheck() function appeared in NetBSD 1.5. BSD
August 3, 2000 BSD

Check Out this Related Man Page

RATECHECK(9)						   BSD Kernel Developer's Manual					      RATECHECK(9)

NAME
ratecheck -- function to help implement rate-limited actions SYNOPSIS
#include <sys/time.h> int ratecheck(struct timeval *lasttime, const struct timeval *mininterval); DESCRIPTION
The ratecheck() function provides a simple time interval check which can be used when implementing time-based rate-limited actions. If the difference between the current monotonically-increasing system time (mono_time) and lasttime is less than the value given by the mininterval argument, zero is returned. Otherwise, lasttime is set to the current time and a non-zero value is returned. The motivation for implementing ratecheck() was to provide a mechanism that could be used to add rate limiting to diagnostic message output. If printed too often, diagnostic messages can keep the system from doing useful work. If the repeated messages can be caused by deliberate user action or network events, they can be exploited to cause denial of system service. Note that using a very short time interval (less than a second) for mininterval defeats the purpose of this function. (It doesn't take much to flood a 9600 baud serial console with output, for instance.) EXAMPLES
Here is a simple example of use of the ratecheck() function: /* * The following variables could be global, in a device softc, etc., * depending on the exact usage. */ struct timeval drv_lasterr1time; /* time of last err1 message */ long drv_err1count; /* # of err1 errs since last msg */ struct timeval drv_lasterr2time; /* time of last err2 message */ long drv_err2count; /* # of err2 errs since last msg */ /* * The following variable will often be global or shared by all * instances of a driver. It should be initialized, so it can be * patched. Allowing it to be set via an option might be nice, * but could lead to an insane proliferation of options. */ struct timeval drv_errintvl = { 5, 0 }; /* 5 seconds */ /* error handling/reporting function */ void drv_errhandler(int err1, int err2) { /* * Note that you should NOT use the same last-event * time variable for dissimilar messages! */ if (err1) { /* handle err1 condition */ ... drv_err1count++; if (ratecheck(&drv_lasterr1notice, &drv_errinterval)) { printf("drv: %ld err1 errors occurred", drv_err1count); drv_err1count = 0; } } if (err2) { /* handle err2 condition */ ... drv_err2count++; if (ratecheck(&drv_lasterr2notice, &drv_errinterval)) { printf("drv: %ld err2 errors occurred", drv_err2count); drv_err2count = 0; } } } SEE ALSO
log(9), ppsratecheck(9), printf(9), time_second(9) HISTORY
The ratecheck() function appeared in NetBSD 1.5. BUGS
ratecheck() may not work as expected, if mininterval is less than the hardware clock interrupt interval (1/hz). BSD
February 2, 2000 BSD
Man Page