|Linux & Unix Commands - Search Man Pages
PROC_FIND(9) BSD Kernel Developer's Manual PROC_FIND(9)
proc_find, pgrp_find -- find process or process group
struct proc *
struct pgrp *
extern kmutex_t *proc_lock;
The proc_find() and pgrp_find() functions retrieve process and process group structures from
process ID pid and process group ID pgid. Both functions must be called by holding a
mutex(9) on proc_lock.
Upon successful completion, the described functions return a pointer to either struct proc
or struct pgrp. Otherwise, if the requested ID was not found, NULL is returned.
BSD July 1, 2010 BSD
All times are GMT -4. The time now is 08:10 PM.