Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

panic(9) [netbsd man page]

PANIC(9)						   BSD Kernel Developer's Manual						  PANIC(9)

NAME
panic -- Bring down system on fatal error SYNOPSIS
#include <sys/types.h> #include <sys/systm.h> void vpanic(const char *fmt, va_list ap); void panic(const char *fmt, ...); DESCRIPTION
The panic() and vpanic() functions terminate the NetBSD system. The message fmt is a printf(3) style format string which is printed to the console and saved in the variable panicstr for later retrieval via core dump inspection. A newline character is added at the end automati- cally, and is thus not needed in the format string. If a kernel debugger is installed, control is passed to it after the message is printed. If the kernel debugger is ddb(4), control may be passed to it, depending on the value of ddb.onpanic. See options(4) for more details on setting ddb.onpanic. If control is not passed through to ddb(4), a ddb(4)-specific function is used to print the kernel stack trace, and then control returns to panic(). If control remains in panic(), an attempt is made to save an image of system memory on the configured dump device. If during the process of handling the panic, panic() is called again (from the filesystem synchronization routines, for example), the system is rebooted immediately without synchronizing any filesystems. panic() is meant to be used in situations where something unexpected has happened and it is difficult to recover the system to a stable state, or in situations where proceeding might make the things worse, leading to data corruption/loss. It is not meant to be used in scenar- ios where the system could easily ignore and/or isolate the condition/subsystem and proceed. In general developers should try to reduce the number of panic() calls in the kernel to improve stability. RETURN VALUES
The panic() function does not return. SEE ALSO
sysctl(3), ddb(4), ipkdb(4), options(4), savecore(8), swapctl(8), sysctl(8) BSD
September 29, 2011 BSD

Check Out this Related Man Page

TEXTDUMP(4)						   BSD Kernel Interfaces Manual 					       TEXTDUMP(4)

NAME
textdump -- textdump kernel dumping facility SYNOPSIS
options KDB options DDB DESCRIPTION
The textdump facility allows the capture of kernel debugging information to disk in a human-readable rather than the machine-readable form normally used with kernel memory dumps and minidumps. This representation, while less complete in that it does not capture full kernel state, can provide debugging information in a more compact, portable, and persistent form than a traditional dump. By combining textdump with other ddb(4) facilities, such as scripting and output capture, detailed bug information can be captured in a fully automated manner. FORMAT
textdump data is stored in a dump partition in the same style as a regular memory dump, and will be automatically extracted by savecore(8) if present on boot. textdump files are stored in the tar(5) format, and consist of one or more text files, each storing a particular type of debugging output. The following parts may be present: ddb.txt Captured ddb(4) output, if the capture facility has been used. May be disabled by clearing the debug.ddb.textdump.do_ddb sysctl. config.txt Kernel configuration, if has been compiled into the kernel. May be disabled by clearing the debug.ddb.textdump.do_config sysctl. msgbuf.txt Kernel message buffer, including recent console output if the capture facility has been used. May be disabled by clearing the debug.ddb.textdump.do_msgbuf sysctl. panic.txt Kernel panic string, if the kernel panicked before the dump was generated. May be disabled by clearing the debug.ddb.textdump.do_panic sysctl. version.txt Kernel version string. My be disabled by clearing the debug.ddb.textdump.do_version sysctl. Kernel textdumps may be extracted using tar(1). CONFIGURATION
The textdump facility is enabled as part of the kernel debugger using options KDB and options DDB. By default, kernel dumps generated on panic or via explicit requests for a dump will be regular memory dumps; however, by using the textdump set command in ddb(4), or by setting the debug.ddb.textdump.pending sysctl to 1 using sysctl(8), it is possible to request that the next dump be a textdump. If at the ddb(4) command line, the commands textdump set, textdump status, and textdump unset may be used to set, query, and clear the textdump pending flag. As with regular kernel dumps, a dump partition must be automatically or manually configured using dumpon(8). EXAMPLES
In the following example, the script kdb.enter.panic will run when the kernel debugger is entered as a result of a panic, enable output cap- ture, dump several useful pieces of debugging information, and then invoke panic in order to force a kernel dump to be written out followed by a reboot: script kdb.enter.panic=textdump set; capture on; show allpcpu; bt; ps; alltrace; show alllock; call doadump; reset In the following example, the script kdb.enter.witness will run when the kernel debugger is entered as a result of a witness violation, printing lock-related information for the user: script kdb.enter.witness=show locks These scripts may also be configured using the ddb(8) utility. SEE ALSO
tar(1), ddb(4), tar(5), ddb(8), dumpon(8), savecore(8), sysctl(8) HISTORY
The textdump facility first appeared in FreeBSD 7.1. AUTHORS
The textdump facility was created by Robert N. M. Watson. BSD
December 24, 2008 BSD
Man Page