memmove(9) [netbsd man page]
MEMMOVE(9) BSD Kernel Developer's Manual MEMMOVE(9) NAME
memmove -- copy byte string SYNOPSIS
#include <sys/systm.h> void * memmove(void *dst, const void *src, size_t len); DESCRIPTION
The memmove() function copies len bytes from string src to string dst. The two strings may overlap; the copy is always done in a non- destructive manner. RETURN VALUES
The memmove() function returns the original value of dst. SEE ALSO
memcpy(9) STANDARDS
The memmove() function conforms to ANSI X3.159-1989 (``ANSI C89''). BSD
July 7, 2001 BSD
Check Out this Related Man Page
MEMMOVE(3) Linux Programmer's Manual MEMMOVE(3) NAME
memmove - copy memory area SYNOPSIS
#include <string.h> void *memmove(void *dest, const void *src, size_t n); DESCRIPTION
The memmove() function copies n bytes from memory area src to memory area dest. The memory areas may overlap: copying takes place as though the bytes in src are first copied into a temporary array that does not overlap src or dest, and the bytes are then copied from the temporary array to dest. RETURN VALUE
The memmove() function returns a pointer to dest. CONFORMING TO
SVr4, 4.3BSD, C89, C99, POSIX.1-2001. SEE ALSO
bcopy(3), memccpy(3), memcpy(3), strcpy(3), strncpy(3), wmemmove(3) COLOPHON
This page is part of release 3.53 of the Linux man-pages project. A description of the project, and information about reporting bugs, can be found at http://www.kernel.org/doc/man-pages/. GNU
1993-04-10 MEMMOVE(3)