LWP_CACHE_CREDS(9) BSD Kernel Developer's Manual LWP_CACHE_CREDS(9)NAME
LWP_CACHE_CREDS -- synchronize LWP credential with process credential
LWP_CACHE_CREDS(lwp_t *l, struct proc *p);
LWP_CACHE_CREDS() updates the LWP's cached credential to match with the process' credential if the latter has been changed after the last
Each LWPs have its cached credential so that it can be used without worrying about potential of other LWP changing the process' credential.
kauth_cred_get() returns the cached credential.
LWP_CACHE_CREDS() is called by MD entry code for system call and various traps. LWPs which can live in kernel for long period should call
LWP_CACHE_CREDS() by itsself to refresh its credential.
LWP_CACHE_CREDS() takes the following arguments.
l The calling lwp.
p The process which the lwp l belongs to.
LWP_CACHE_CREDS() might be implemented as a macro.
SEE ALSO intro(9), kauth(9)BSD December 9, 2007 BSD
Check Out this Related Man Page
_LWP_KILL(2) BSD System Calls Manual _LWP_KILL(2)NAME
_lwp_kill -- send a signal to a light-weight process
Standard C Library (libc, -lc)
_lwp_kill(lwpid_t lwp, int sig);
_lwp_kill() sends the signal specified by sig to the light-weight process specified by lwp. If the sig argument is given as 0 (zero),
_lwp_kill will test for the existence of the target LWP, but will take no further action.
Job control signals and uncatchable signals can not be directed to a specific LWP: if posted with _lwp_kill, they will affect all LWPs in the
Signals will be posted successfully to suspended LWPs, but will not be handled further until the LWP has been continued.
A 0 value indicates that the call succeeded. A -1 return value indicates an error occurred and errno is set to indicate the reason.
[EINVAL] sig is not a valid signal number.
[ESRCH] No LWP can be found in the current process corresponding to that specified by lwp.
SEE ALSO _lwp_continue(2), _lwp_suspend(2), kill(2), sigaction(2), signal(7)HISTORY
The _lwp_kill() system call first appeared in NetBSD 5.0.
BSD January 20, 2007 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)