lockmgr(9) [netbsd man page]
LOCK(9) BSD Kernel Developer's Manual LOCK(9) NAME
lock, simple_lock_init, simple_lock, simple_lock_try, simple_unlock, simple_lock_freecheck, simple_lock_dump, lockinit, lockmgr, lockstatus, lockmgr_printinfo, spinlockinit, spinlockmgr -- kernel lock functions DESCRIPTION
These interfaces have been obsoleted and removed from the system. Please see the condvar(9), mutex(9), and rwlock(9) manual pages for information on kernel synchronisation primitives. SEE ALSO
condvar(9), mutex(9), rwlock(9) HISTORY
The kernel locking API first appeared in 4.4BSD-lite2, and was replaced in NetBSD 5.0. BSD
January 30, 2008 BSD
Check Out this Related Man Page
simple_lock_init(9r) simple_lock_init(9r) NAME
simple_lock_init - General: Initializes a simple lock structure SYNOPSIS
#include <kern/lock.h> void simple_lock_init( simple_lock_t slock_ptr ); ARGUMENTS
Specifies a pointer to a simple lock structure. You can declare this simple lock structure by using the decl_simple_lock_data routine. DESCRIPTION
The simple_lock_init routine initializes the simple lock structure that you previously declared with the decl_simple_lock_data routine. You need to initialize the simple lock structure only once. After you initialize the simple lock structure, you can call simple_lock to assert exclusive access on the associated resource. RETURN VALUES
None FILES
SEE ALSO
Routines: decl_simple_lock_data(9r), simple_lock(9r), simple_lock_terminate(9r), simple_lock_try(9r), simple_unlock(9r) Data Structures: slock(9s) simple_lock_init(9r)