netbsd man page for itimerfix

Query: itimerfix

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ITIMERFIX(9)						   BSD Kernel Developer's Manual					      ITIMERFIX(9)

NAME
itimerfix -- check that a timeval value is valid, and correct
SYNOPSIS
#include <sys/time.h> int itimerfix(struct timeval *tv);
DESCRIPTION
The itimerfix function checks that the value in tv is valid (0 <= tv->tv_sec && 0 <= tv->tv_usec < 1000000), and that the total time repre- sented is at least one tick, or zero. If the total represented time is nonzero and smaller than tick, it is adjusted to exactly one tick.
RETURN VALUES
itimerfix returns 0 on success or EINVAL if tv is invalid.
SEE ALSO
nanosleep(2), poll(2), select(2), setitimer(2)
BSD
November 23, 2001 BSD
Related Man Pages
timeradd(3) - centos
timerclear(3) - centos
timerisset(3) - centos
timeradd(3) - freebsd
timespec(3) - netbsd
Similar Topics in the Unix Linux Community
Unix File Permissions
NetBSD 6.1.2: apm and admd not found
RFC - Korn shell prompt