Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ieee80211_input(9) [netbsd man page]

IEEE80211_INPUT(9)					   BSD Kernel Developer's Manual					IEEE80211_INPUT(9)

NAME
ieee80211_input, ieee80211_decap, ieee80211_recv_mgmt -- software 802.11 stack input functions SYNOPSIS
#include <net80211/ieee80211_var.h> #include <net80211/ieee80211_proto.h> void ieee80211_input(struct ieee80211com *ic, struct mbuf *m, struct ieee80211_node *ni, int rssi, u_int32_t rstamp); struct mbuf * ieee80211_decap(struct ieee80211com *ic, struct mbuf *m); void ieee80211_recv_mgmt(struct ieee80211com *ic, struct mbuf *m0, struct ieee80211_node *ni, int subtype, int rssi, u_int32_t rstamp); DESCRIPTION
These functions process received 802.11 frames. The ieee80211_input() function takes an mbuf chain m containing a complete 802.11 frame from the driver ic and passes it to the software 802.11 stack for input processing. The ni argument specifies an instance of struct ieee80211_node (which may be driver-specific) represent- ing the node from which the frame was received. The arguments rssi and stamp are typically derived from on-card data structures; they are used for recording the signal strength and time received of the frame respectively. The ieee80211_decap() function performs decapsulation of the 802.11 frame in the mbuf chain m received by the device ic, taking the form of the 802.11 address fields into account; the structure of 802.11 addresses vary according to the intended source and destination of the frame. It is typically called from within ieee80211_input(). The ieee80211_recv_mgmt() performs input processing for 802.11 management frames. It is typically called from within ieee80211_input(). SEE ALSO
ieee80211(9) HISTORY
The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6. AUTHORS
This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>. BUGS
There is no netisr queue specifically for the software 802.11 stack yet. BSD
September 12, 2006 BSD

Check Out this Related Man Page

IEEE80211_IOCTL(9)					   BSD Kernel Developer's Manual					IEEE80211_IOCTL(9)

NAME
ieee80211_cfgget, ieee80211_cfgset, ieee80211_ioctl -- 802.11 interface ioctl commands SYNOPSIS
#include <net80211/ieee80211_var.h> #include <net80211/ieee80211_proto.h> #include <net80211/ieee80211_ioctl.h> int ieee80211_cfgget(struct ieee80211com *ic, u_long cmd, void *data); int ieee80211_cfgset(struct ieee80211com *ic, u_long cmd, void *data); int ieee80211_ioctl(struct ieee80211com *ic, u_long cmd, void *data); DESCRIPTION
These functions are typically invoked by drivers in response to requests for information or to change settings from the userland. The ieee80211_cfgget() and ieee80211_cfgset() functions implement a legacy interface for getting and setting 802.11 interface attributes respectively. The interface is compatible with the RIDs implemented by the wi(4) driver and used by the wiconfig(8) utility. The ieee80211_ioctl() function implements ioctls such as key management for wireless devices. Ioctls related to the Ethernet layer also pass through here, but are handed off to ether_ioctl() when no match for cmd is found. SEE ALSO
wi(4), ifconfig(8), wiconfig(8), ieee80211(9) HISTORY
The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6. AUTHORS
This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>. BSD
September 12, 2006 BSD
Man Page

4 More Discussions You Might Find Interesting

1. Linux

How to enable 802.1x in Redhat 9

Hey All, I have some clarification regarding how to install 802.1x in redhat 9 or how to enable this 802.1x. Regards Alex :) (0 Replies)
Discussion started by: solaris8in
0 Replies

2. Shell Programming and Scripting

cutting unwanted text

Hello, I have a log file which looks like this : I want to cut out some text and get printed only : "HTTP GET" and "Time duration: 1013 mls. (1 sec.)" I tried searching the forum for such solution, but I was unable to find it. I also tried awk '/duration/ { print $0 }' mylogfile.log,... (2 Replies)
Discussion started by: sysgate
2 Replies

3. IP Networking

TCP/IP in 802.3 and 802.11 frame

I'm new to networking world. So please bear with me. My Questions: 1. How do we send TCP/IP in a 802.3 frame? My understanding is that we have to incorporate the 802.3 LLC layer. The DSAP and SSAP in the LLC layer will provide information of the type of data inside the Information field of... (0 Replies)
Discussion started by: Lukas
0 Replies

4. Shell Programming and Scripting

expect_out(buffer) empty

I have only some info into my buffer, but after a rssi command I see the folowing lines expected into buffer but not present : rssi=-106 rssi=-109 I see in my buffer only the first part of the output, here you are a part of script : #!/usr/bin/expect -f #global expect_out match_max 10000000... (1 Reply)
Discussion started by: ugobale
1 Replies