|Linux & Unix Commands - Search Man Pages
ROUNDUP(9) BSD Kernel Developer's Manual ROUNDUP(9)
roundup -- macros for counting and rounding
The roundup() and rounddown() macros return an integer from rounding x up and down, respec-
tively, to the next size. The howmany() macro in turn reveals how many times size fits into
x, rounding the residual up.
The roundup2() macro also rounds up, but with the assumption that size is a power of two.
If x is indeed a power of two, powerof2() return 1.
The return value is an integer from the respective operation. If x is 0, all macros except
powerof2() return 0. The behavior is undefined if size is 0.
The following example rounds the variable rx to a 32-bit boundary:
rx = roundup2(rx, sizeof(uint32_t));
ilog2(3), param(3), imax(9)
All described macros make no assumptions about the type of the parameters. These are
implicitly assumed to be unsigned integers.
BSD June 1, 2011 BSD
All times are GMT -4. The time now is 09:49 AM.