ERRNO(9) BSD Kernel Developer's Manual ERRNO(9)NAME
errno -- kernel internal error numbers
SYNOPSIS
#include <sys/errno.h>
DESCRIPTION
This section provides an overview of the error numbers used internally by the kernel and indicate neither success nor failure. These error
numbers are not returned to userland code.
DIAGNOSTICS
Kernel functions that indicate success or failure by means of either 0 or an errno(2) value sometimes have a need to indicate that
``special'' handling is required at an upper layer or, in the case of ioctl(2) processing, that ``nothing was wrong but the request was not
handled''. To handle these cases, some negative errno(2) values are defined which are handled by the kernel before returning a different
errno(2) value to userland or simply zero.
The following is a list of the defined names and their meanings as given in <errno.h>. It is important to note that the value -1 is not
used, since it is commonly used to indicate generic failure and leaves it up to the caller to determine the action to take.
-2 EJUSTRETURN Modify regs, just return. No more work is required and the function should just return.
-3 ERESTART Restart syscall. The system call should be restarted. This typically means that the machine dependent system call trap code
will reposition the process's instruction pointer or program counter to re-execute the current system call with no other work
required.
-4 EPASSTHROUGH Operation not handled by this layer. The operation was not handled and should be passed through to another layer. This
often occurs when processing ioctl(2) requests since lower layer processing may not handle something that subsequent code at a higher
level will.
-5 EDUPFD Duplicate file descriptor. This error is returned from the device open routine indicating that the l_dupfd field contains the file
descriptor information to be returned to the caller, instead of the file descriptor that has been opened already. This error is used
by cloning device multiplexors. Cloning device multiplexors open a new file descriptor and associate that file descriptor with the
appropriate cloned device. They set l_dupfd to that new file descriptor and return EDUPFD. vn_open(9) takes the file descriptor
pointed to by l_dupfd and copies it to the file descriptor that the open call will return.
-6 EMOVEFD Move file descriptor. This error is similar to EDUPFD except that the file descriptor in l_dupfd is closed after it has been
copied.
SEE ALSO errno(2), ioctl(9)HISTORY
An errno manual page appeared in Version 6 AT&T UNIX. This errno manual page appeared in NetBSD 3.0.
BSD December 3, 2004 BSD
Check Out this Related Man Page
DUP(2) BSD System Calls Manual DUP(2)NAME
dup, dup2 -- duplicate an existing file descriptor
LIBRARY
Standard C Library (libc, -lc)
SYNOPSIS
#include <unistd.h>
int
dup(int oldd);
int
dup2(int oldd, int newd);
DESCRIPTION
The dup() system call duplicates an existing object descriptor and returns its value to the calling process (newd = dup(oldd)). The argument
oldd is a small non-negative integer index in the per-process descriptor table. The value must be less than the size of the table, which is
returned by getdtablesize(2). The new descriptor returned by the call is the lowest numbered descriptor currently not in use by the process.
The object referenced by the descriptor does not distinguish between oldd and newd in any way. Thus if newd and oldd are duplicate refer-
ences to an open file, read(2), write(2) and lseek(2) calls all move a single pointer into the file, and append mode, non-blocking I/O and
asynchronous I/O options are shared between the references. If a separate pointer into the file is desired, a different object reference to
the file must be obtained by issuing an additional open(2) system call. The close-on-exec flag on the new file descriptor is unset.
In dup2(), the value of the new descriptor newd is specified. If this descriptor is already in use and oldd != newd, the descriptor is first
deallocated as if the close(2) system call had been used. If oldd is not a valid descriptor, then newd is not closed. If oldd == newd and
oldd is a valid descriptor, then dup2() is successful, and does nothing.
RETURN VALUES
The value -1 is returned if an error occurs in either call. The external variable errno indicates the cause of the error.
ERRORS
The dup() and dup2() system calls fail if:
[EBADF] The oldd or newd argument is not a valid active descriptor
[EMFILE] Too many descriptors are active.
SEE ALSO accept(2), close(2), fcntl(2), getdtablesize(2), open(2), pipe(2), socket(2), socketpair(2)STANDARDS
The dup() and dup2() system calls are expected to conform to ISO/IEC 9945-1:1990 (``POSIX.1'').
HISTORY
The dup() and dup2() functions appeared in Version 7 AT&T UNIX.
BSD June 4, 1993 BSD