Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

dumpsys(9) [netbsd man page]

CPU_DUMPCONF(9) 					   BSD Kernel Developer's Manual					   CPU_DUMPCONF(9)

NAME
cpu_dumpconf, cpu_dump, cpu_dumpsize, dumpsys -- machine-dependent kernel core dumps SYNOPSIS
#include <sys/types.h> #include <sys/systm.h> void cpu_dumpconf(void); int cpu_dump(int (*dump)(dev_t, daddr_t, void *, size_t), daddr_t *blknop); int cpu_dumpsize(void); void dumpsys(void); DESCRIPTION
cpu_dumpconf() is the machine-dependent interface invoked during system bootstrap to determine the dump device and initialize machine-depen- dent kernel core dump state. Internally, cpu_dumpconf() will invoke cpu_dumpsize() to calculate the size of machine-dependent kernel core dump headers. dumpsys() is invoked by cpu_reboot() to dump kernel physical memory onto the dump device. dumpsys() invokes cpu_dump() to write the machine- dependent header to the dump device at block number *blknop using the dump device's PIO dump routine specified by the dump argument. cpu_dumpsize(), cpu_dump(), and dumpsys() are parts of the machine-dependent interface, however they are not exported to machine-independent code. SEE ALSO
cpu_reboot(9) BSD
May 24, 2002 BSD

Check Out this Related Man Page

dump(9E)							Driver Entry Points							  dump(9E)

NAME
dump - dump memory to device during system failure SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> intprefixdump(dev_t dev, caddr_t addr, daddr_t blkno, int nblk); INTERFACE LEVEL
Solaris specific (Solaris DDI). This entry point is required. For drivers that do not implement dump() routines, nodev(9F) should be used. ARGUMENTS
dev Device number. addr Address for the beginning of the area to be dumped. blkno Block offset to dump memory. nblk Number of blocks to dump. DESCRIPTION
dump() is used to dump a portion of virtual address space directly to a device in the case of system failure. It can also be used for checking the state of the kernel during a checkpoint operation. The memory area to be dumped is specified by addr (base address) and nblk (length). It is dumped to the device specified by dev starting at offset blkno. Upon completion dump() returns the status of the transfer. When the system is panicking, the calls of functions scheduled by timeout(9F) and ddi_trigger_softintr(9F) will never occur. Neither can delay(9F) be relied upon, since it is implemented via timeout(). See ddi_in_panic(9F). dump() is called at interrupt priority. RETURN VALUES
dump() returns 0 on success, or the appropriate error number. SEE ALSO
cpr(7), nodev(9F) Writing Device Drivers SunOS 5.10 9 Oct 2001 dump(9E)
Man Page