CTOD(9) BSD Kernel Developer's Manual CTOD(9)NAME
ctod -- macros related to bytes, pages, and disk blocks
SYNOPSIS
#include <sys/param.h>
size
ctod(size x);
size
dtoc(size x);
size
ctob(size x);
size
btoc(size x);
size
dbtob(size x);
size
btodb(size x);
DESCRIPTION
The ctod family of macros can be used to convert between bytes, pages (``clicks''), and disk blocks.
The following table lists the possible conversions:
Macro From To
ctod() pages disk blocks
dtoc() disk blocks pages
ctob() pages bytes
btoc() bytes pages
dbtob() disk blocks bytes
btodb() bytes disk blocks
These are typical macros that may appear with different names in other operating systems. Examples include btop() and btopr() in Solaris.
SEE ALSO param(3)HISTORY
Some of these macros appeared in Version 7 AT&T UNIX.
CAVEATS
The described macros make no assumptions about the type of the input parameter. A caller should ensure that neither integer overflow nor
integer underflow are possible.
BSD April 8, 2011 BSD
Check Out this Related Man Page
PARAM(3) BSD Library Functions Manual PARAM(3)NAME
param -- common parameters
SYNOPSIS
#include <sys/param.h>
size
MAX(size a, size b);
size
MIN(size a, size b);
DESCRIPTION
The <sys/param.h> header includes some common definitions and macros specific to NetBSD. The header is perhaps best characterized as a ker-
nel equivalent of <sys/types.h>. The following list summarizes the provided definitions and macros.
o First and foremost, the header defines the version of NetBSD. This is defined as
#define __NetBSD_Version__ 599004800 /* 5.99.48 */
The general format is ``MMmmrrpp00'', where 'MM' and 'mm' denote the major and minor version, respectively, 'rr' is provided for
compatibility, and 'pp' defines the patch level.
o Common utility macros such as MAX() and MIN() as well as more specific macros such as STACK(9), ctod(9), mstohz(9), roundup(9), and
setbit(9).
o Numerous miscellaneous definitions such as limits, constants for the kernel memoryallocators(9), scale factors used by the sched-
uler, kthread(9) priorities, and many others.
o Definitions provided for historical and compatibility reasons. Examples range from definitions such as ``#define BSD'' to old pri-
ority levels used in the kernel.
SEE ALSO bitops(3), cdefs(3), types(3), unistd(3)HISTORY
A <param.h> header appeared already in the Version 4 AT&T UNIX.
BSD April 10, 2011 BSD
I have a Java program which will automatically trigger some scheduled job to update Db or some other work. I am tracking the jobs with log messages and finding out it is properly run or not. I want to write a script to capture it correctly on time.
Say Job1 is running on 15, 30, and 45 every... (5 Replies)
Hi,
I'm trying to check if methods specified in a class have been added to the corrosponding interface.
My code below is giving me the following errors:
grep: function: No such file or directory
grep: import($zipfile): No such file or directory
grep: function: No such file or... (1 Reply)
Dear Team:
I am new to this Forum and I need your help for my AIX restoration problem
its very urgent
my problem as follow
failure I have a Tivoli Storage Manger was installed on that server.
I created backup image using Tivoli and it created a set of files each file is around 2GB
so... (1 Reply)
Hi,
In a error log file, the error code of a particular error contains both Alphabet and Numbers. My problem statement is to find the error codes from a particular log. That means, I need to search a word, which contains both alphabet and number. Please help me. Below is two examples of error... (1 Reply)
Suppose there are log entries like
16 Jul 2012 11:46:45,628 SendToClientService ExecuteThread: '256' for queue: 'weblogic.kernel.Default (self-tuning)': Received an unknown fault.
16 Jul 2012 11:47:45,650 SendToClientService ExecuteThread: '256' for queue: 'weblogic.kernel.Default... (4 Replies)
Good afternoon all,
First, sorry for my English, this is not my first language but I try my best :).
So, here we go.
A friend of mine gave me an old Sun Blade 1500 he wasn't using. He said it was working fine except for the missing hard drive.
I had in my IT personnal box an old IDE... (33 Replies)
Okay so I posted a thread about my project before, how I need to create generated word ladders and all that. Now I am to the point where I need to create a method which will find the shortests path between a start word and an end word. For example:
startWord: Head
endWord: Feet
And then a... (3 Replies)
Okay so I am currently workng on an assignment where I have basically got to create a word ladder, eg. Click, Clock, Flock, Flick, so its a list of words with only 1 letter difference, and the same letters cant be reused. Now I can do 2 methods of doing this, the first (which I need help need help... (2 Replies)
Hi
I tried to boot as single-user mode on my sunfire t1000 to change my root password since the guy has left the company without give us the root password.
anyhow since this machine not have attached with cd/dvd/usb so the only think that to do it through Jumpstart
now i tried to... (8 Replies)
Hello,
I was handed the job of restoring a drive on a old Sun Micro server running Solaris 8. The person who created the backup files told me I would need to use UFSrestore to restore the drive. I have read about everything on ufsrestore that is on this forum and have a decent grasp on how it... (18 Replies)
Please bear with me, I'm a beginner but have had some experience and decent knowledge to understand things as I read them and I'm in the process of trying to learn more. I recently inherited a UNIX server which has a bash script which is part of a crontab schedule that needs to be modified (or... (3 Replies)
Hello,
I'm trying to branch out and learn Linux, but my comfort zone is PowerShell. I figure the best way to learn it is to do it so I moved my Plex Media Server to Ubuntu Server.
What I'm trying to do is build a script that searches a directory and all subdirectories for files with the .ts... (5 Replies)