DOPOWERHOOKS(9) BSD Kernel Developer's Manual DOPOWERHOOKS(9)NAME
dopowerhooks -- run all power hooks
The dopowerhooks routine is deprecated. Use pmf_system_suspend(9) instead.
The dopowerhooks() function invokes all power hooks established using the powerhook_establish(9) function. When power is disappearing the
power hooks are called in reverse order, i.e., the power hook established last will be called first. When power is restored they are called
This function is called from the apm(4) driver when a power change is detected.
SEE ALSO powerhook_establish(9)BSD February 11, 2010 BSD
Check Out this Related Man Page
power(9E) Driver Entry Points power(9E)NAME
power - power a device attached to the system
int prefixpower(dev_info_t *dip, int component, int level);
Solaris DDI specific (Solaris DDI). This entry point is required. If the driver writer does not supply this entry point, the value NULL
must be used in the cb_ops(9S) structure instead.
dip Pointer to the device's dev_info structure.
component Component of the driver to be managed.
level Desired component power level.
The power(9E) function is the device-specific Power Management entry point. This function is called when the system wants the driver to set
the power level of component to level.
The level argument is the driver-defined power level to which the component needs to be set. Except for power level 0, which is inter-
preted by the framework to mean "powered off," the interpretation of level is entirely up to the driver.
The component argument is the component of the device to be power-managed. The interpretation of component is entirely up to the driver.
When a requested power transition would cause the device to lose state, the driver must save the state of the device in memory. When a
requested power transition requires state to be restored, the driver must restore that state.
If a requested power transition for one component requires another component to change power state before it can be completed, the driver
must call pm_raise_power(9F) to get the other component changed, and the power(9E) entry point must support being re-entered.
If the system requests an inappropriate power transition for the device (for example, a request to power down a device which has just
become busy), then the power level should not be changed and power should return DDI_FAILURE.
The power() function returns:
DDI_SUCCESS Successfully set the power to the requested level.
DDI_FAILURE Failed to set the power to the requested level.
The power() function is called from user or kernel context only.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Interface stability |Evolving |
SEE ALSO attach(9E), detach(9E), pm_busy_component(9F), pm_idle_component(9F), pm_raise_power(9F), cb_ops(9S)
Writing Device Drivers
Using Power Management
SunOS 5.10 12 Dec 2003 power(9E)
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)