CURPROC(9) BSD Kernel Developer's Manual CURPROC(9)NAME
curproc, curcpu, curlwp -- current process, processor, and LWP
SYNOPSIS
#include <sys/proc.h>
struct cpu_info *
curcpu(void);
struct proc *
curproc(void);
struct lwp *
curlwp(void);
DESCRIPTION
The following macros can be used to retrieve the current processor, process, and light-weight process (LWP), respectively:
1. The machine-dependent curcpu() macro returns a pointer to a cpu_info structure containing information of the CPU that this thread
is running on.
2. The machine-independent curproc() macro refers to a pointer to the process currently running on this CPU.
3. The curlwp() macro expands to a pointer to lwp structure, containing information about the current LWP. This macro is machine-
independent, but machine-dependent <machine/cpu.h> may redefine it.
SEE ALSO cpu_number(9), proc_find(9)BSD July 1, 2010 BSD
Check Out this Related Man Page
CPU_NEED_RESCHED(9) BSD Kernel Developer's Manual CPU_NEED_RESCHED(9)NAME
cpu_need_resched -- context switch notification
SYNOPSIS
#include <sys/cpu.h>
void
cpu_need_resched(struct cpu_info *ci, int flags);
DESCRIPTION
The cpu_need_resched() function is the machine-independent interface for the scheduler to notify machine-dependent code that a context switch
from the current LWP, on the cpu ci, is required. This event may occur if a higher priority LWP appears on the run queue or if the current
LWP has exceeded its time slice.
If RESCHED_KPREEMPT flag is specified in flags and __HAVE_PREEMPTION C pre-processor macro is defined in <machine/intr.h>, machine-dependent
code should make a context switch happen as soon as possible even if the cpu is running the kernel code.
If RESCHED_IMMED flag is specified in flags, machine-dependent code should make a context switch happen as soon as possible. In that case,
for example, if ci is not the current processor, cpu_need_resched() typically issues an inter processor call to the processor to make it
notice the need of a context switch as soon as possible.
Typically, the cpu_need_resched() function will perform the following operations:
o Set a per-processor flag which is checked by userret(9) when returning to user-mode execution.
o Post an asynchronous software trap (AST).
o Send an inter processor interrupt to wake up cpu_idle(9).
SEE ALSO sched_4bsd(9), userret(9)BSD July 31, 2010 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)