|Linux & Unix Commands - Search Man Pages
CTASSERT(9) BSD Kernel Developer's Manual CTASSERT(9)
CTASSERT -- compile time assertion macro
The CTASSERT() macro evaluates expression at compile time and causes a compiler error if it
The CTASSERT() macro is useful for asserting the size or alignment of important data struc-
tures and variables during compilation, which would otherwise cause the code to fail at run
The CTASSERT() macro should not be used in a header file. It is implemented using a dummy
typedef, with a name (based on line number) that may conflict with a CTASSERT() in a source
file including that header.
Assert that the size of the uuid structure is 16 bytes.
CTASSERT(sizeof(struct uuid) == 16);
This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
BSD January 24, 2010 BSD
All times are GMT -4. The time now is 07:47 AM.