CTASSERT(9) BSD Kernel Developer's Manual CTASSERT(9)NAME
CTASSERT -- compile time assertion macro
SYNOPSIS
void
CTASSERT(expression);
DESCRIPTION
The CTASSERT() macro evaluates expression at compile time and causes a compiler error if it is false.
The CTASSERT() macro is useful for asserting the size or alignment of important data structures and variables during compilation, which would
otherwise cause the code to fail at run time.
IMPLEMENTATION NOTES
The CTASSERT() macro should not be used in a header file. It is implemented using a dummy typedef, with a name (based on line number) that
may conflict with a CTASSERT() in a source file including that header.
EXAMPLES
Assert that the size of the uuid structure is 16 bytes.
CTASSERT(sizeof(struct uuid) == 16);
SEE ALSO KASSERT(9)AUTHORS
This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
BSD January 24, 2010 BSD
Check Out this Related Man Page
_DIAGASSERT(3) BSD Library Functions Manual _DIAGASSERT(3)NAME
_DIAGASSERT -- expression verification macro
SYNOPSIS
#include <assert.h>
_DIAGASSERT(expression);
DESCRIPTION
The _DIAGASSERT() macro tests the given expression and if it is false, one or more of the following may occur:
o a diagnostic message may be logged to the system logger with syslog(3). This is default behaviour.
o a diagnostic message may be printed to the stderr stream.
o the calling process will be terminated by calling abort(3).
This behaviour may be changed by setting the LIBC_DIAGASSERT environment variable (see below).
The diagnostic message consists of the text of the expression, the name of the source file, the line number and the enclosing function.
If expression is true, the _DIAGASSERT() macro does nothing.
The _DIAGASSERT() macro is not compiled in by default, and will only be compiled in with the cc(1) option -D_DIAGNOSTIC.
This macro is used in the various system libraries such as the Standard C Library (libc, -lc) to ensure that various library calls are
invoked with valid arguments.
ENVIRONMENT
The LIBC_DIAGASSERT environment variable can be used to modify the default behaviour of logging the assertion to the system logger.
LIBC_DIAGASSERT may be set to one or more of the following characters:
a abort(3) once any assertion messages have been logged and/or printed.
A Opposite of ``a''.
e Print the assertion message to the stderr stream.
E Opposite of ``e''.
l Log the assertion message with syslog(3) to the facility user.debug.
L Opposite of ``l''.
DIAGNOSTICS
The diagnostic message has the following format:
"assertion "%s" failed: file "%s", line %d, function "%s"
",
"expression", __FILE__, __LINE__, __func__
SEE ALSO cc(1), abort(3), assert(3), syslog(3)HISTORY
The _DIAGASSERT macro appeared in NetBSD 1.5.
BSD January 22, 2007 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)