CPU_INITCLOCKS(9) BSD Kernel Developer's Manual CPU_INITCLOCKS(9)NAME
cpu_initclocks -- machine-dependent clock setup interface
SYNOPSIS
#include <sys/systm.h>
void
cpu_initclocks(void);
DESCRIPTION
cpu_initclocks() is invoked by initclocks() during system bootstrap, immediately after autoconfiguration, to perform the machine-dependent
initialization of clock frequencies and start the real-time and statistic clocks running.
CODE REFERENCES
Machine-independent clock interface operations are performed within the file sys/kern/kern_clock.c.
SEE ALSO autoconf(9)BSD May 24, 2002 BSD
Check Out this Related Man Page
HZ(9) BSD Kernel Developer's Manual HZ(9)NAME
hz, tick, tickadj, stathz, profhz -- system time model
SYNOPSIS
#include <sys/kernel.h>
extern int hz;
extern int tick;
extern int tickadj;
extern int stathz;
extern int profhz;
DESCRIPTION
The essential clock handling routines in NetBSD are written to operate with two timers that run independently of each other. The main clock,
running hz times per second, is used to keep track of real time.
In another words, hz specifies the number of times the hardclock(9) timer ticks per second. Normally hardclock(9) increments time by tick
each time it is called. If the system clock has drifted, adjtime(2) may be used to skew this increment based on the rate of tickadj.
The second timer is used to gather timing statistics. It also handles kernel and user profiling. If the second timer is programmable, it is
randomized to avoid aliasing between the two clocks. The mean frequency of the second timer is stathz. If a separate clock is not avail-
able, stathz is set to hz.
If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which is required to be a multiple of
stathz. This will give higher resolution profiling information.
These system variables are also available as struct clockinfo from sysctl(3) and kern.clockrate from sysctl(8). The hz is hardware-depen-
dent; it can be overridden (if the machine dependent code supports this) by defining HZ in the kernel configuration file (see options(4)).
Only override the default value if you really know what you are doing.
SEE ALSO adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9)BSD March 25, 2010 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)