Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

cpu_idle(9) [netbsd man page]

CPU_IDLE(9)						   BSD Kernel Developer's Manual					       CPU_IDLE(9)

NAME
cpu_idle -- machine-dependent processor idling interface SYNOPSIS
#include <sys/cpu.h> void cpu_idle(void); DESCRIPTION
cpu_idle() is called by machine-independent code when the processor has nothing to do. It can be used to conserve the processor power, for example. cpu_idle() returns immediately if cpu_need_resched() has been called for the processor after the last call of cpu_idle() or cpu_did_resched() on the processor. cpu_idle() returns as soon as possible when cpu_need_resched() is called for the processor. Otherwise, it returns when- ever it likes. cpu_idle() is called at IPL_NONE, without any locks held. EXAMPLES
The simplest (and, in some cases, the best) implementation of cpu_idle() is the following. void cpu_idle(void) { /* nothing */ } SEE ALSO
cpu_need_resched(9), cpu_switchto(9), intro(9), spl(9) BSD
April 20, 2007 BSD

Check Out this Related Man Page

pset_info(1)						      General Commands Manual						      pset_info(1)

NAME
pset_info - Displays processor set information SYNOPSIS
/usr/sbin/pset_info DESCRIPTION
The pset_info command displays information about processor sets and the processors that are assigned to each set. Note that a stopped pro- cessor is not a member of any processor set, and its processor set identification number is specified as -1. Also, depending on the machine architecture, processors may not be numbered consecutively. That is, a four-processor system may not have a processor with the number 3. NOTES
If a processor or processor set is queried while it is in transition (for example, processor set destruction or processor assignment), an error may be returned from the kernel. Running the command a second time will result in normal behavior. EXAMPLES
The following is an example of the output of the pset_info command: number of processor sets on system = 2 pset_id # cpus # pids # threads load_av created 0 1 26 63 0.90 09/21/1994 17:48:42 6 1 1 4 0.21 09/21/1994 23:33:37 total number of processors on system = 3 cpu # running boot_cpu pset_id assigned_to_pset 0 1 1 0 09/21/1994 17:48:42 1 1 0 6 09/21/1994 23:34:06 2 0 0 -1 09/21/1994 17:48:42 SEE ALSO
Commands: pset_assign_cpu(1), pset_assign_pid(1), pset_create(1), psradm(8) Files: processor_sets(4) pset_info(1)
Man Page

6 More Discussions You Might Find Interesting

1. Solaris

CPU idle

hi when should we consider that CPU is loaded? When it is 100% idle or 0%idle?? tx (4 Replies)
Discussion started by: melanie_pfefer
4 Replies

2. HP-UX

vmstat displays cpu idle time at 100%

Since yesterday the vmstat command is displaying the cpu idle time at 100%At each time interval. It never changes. Not sure what it means other than it Quit calculating that stat. And I'm curious why. Using sar I can display a correctCpu idle percent, but vmstat does not. Any ideas why or... (2 Replies)
Discussion started by: tfrye
2 Replies

3. Shell Programming and Scripting

How to get the information about cpu idle from top command?

I am using Ubuntu 9.04. I want to write a shell script to get the information about cpu idle from top command at the real time when i call it, compare cpu idle with 20 (20%), if cpu idle > 20 exit 1, vice versa exit 0. Anybody can help me to resolve it ? Thanks alot. (7 Replies)
Discussion started by: huyquocnguyen
7 Replies

4. Solaris

top is showing 0% cpu Idle

What should we do if we show a 0% cpu idl on top? (5 Replies)
Discussion started by: Pouchie1
5 Replies

5. Shell Programming and Scripting

Help on shell script conditional execution when CPU Idle > 60%

I need a shell script that will monitor a few conditions and not execute until the these conditions are met. The problem I'm having is that I can not perform a database snapshot (backup) of a sybaseIQ database unless the CPU Status Idle % is above 60% or the snapshot (backup) fails. If... (2 Replies)
Discussion started by: pancona99
2 Replies

6. Solaris

Why CPU idle 0 process nohub lose

Hello Solaris 8 when CPU idle 0 . why nohub process lose ? Thank (1 Reply)
Discussion started by: ppmanja
1 Replies