CPU_DUMPCONF(9) BSD Kernel Developer's Manual CPU_DUMPCONF(9)NAME
cpu_dumpconf, cpu_dump, cpu_dumpsize, dumpsys -- machine-dependent kernel core dumps
SYNOPSIS
#include <sys/types.h>
#include <sys/systm.h>
void
cpu_dumpconf(void);
int
cpu_dump(int (*dump)(dev_t, daddr_t, void *, size_t), daddr_t *blknop);
int
cpu_dumpsize(void);
void
dumpsys(void);
DESCRIPTION
cpu_dumpconf() is the machine-dependent interface invoked during system bootstrap to determine the dump device and initialize machine-depen-
dent kernel core dump state. Internally, cpu_dumpconf() will invoke cpu_dumpsize() to calculate the size of machine-dependent kernel core
dump headers.
dumpsys() is invoked by cpu_reboot() to dump kernel physical memory onto the dump device. dumpsys() invokes cpu_dump() to write the machine-
dependent header to the dump device at block number *blknop using the dump device's PIO dump routine specified by the dump argument.
cpu_dumpsize(), cpu_dump(), and dumpsys() are parts of the machine-dependent interface, however they are not exported to machine-independent
code.
SEE ALSO cpu_reboot(9)BSD May 24, 2002 BSD
Check Out this Related Man Page
dump(9E) Driver Entry Points dump(9E)NAME
dump - dump memory to device during system failure
SYNOPSIS
#include <sys/types.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>
intprefixdump(dev_t dev, caddr_t addr, daddr_t blkno, int nblk);
INTERFACE LEVEL
Solaris specific (Solaris DDI). This entry point is required. For drivers that do not implement dump() routines, nodev(9F) should be used.
ARGUMENTS
dev Device number.
addr Address for the beginning of the area to be dumped.
blkno Block offset to dump memory.
nblk Number of blocks to dump.
DESCRIPTION
dump() is used to dump a portion of virtual address space directly to a device in the case of system failure. It can also be used for
checking the state of the kernel during a checkpoint operation. The memory area to be dumped is specified by addr (base address) and nblk
(length). It is dumped to the device specified by dev starting at offset blkno. Upon completion dump() returns the status of the transfer.
When the system is panicking, the calls of functions scheduled by timeout(9F) and ddi_trigger_softintr(9F) will never occur. Neither can
delay(9F) be relied upon, since it is implemented via timeout(). See ddi_in_panic(9F).
dump() is called at interrupt priority.
RETURN VALUES
dump() returns 0 on success, or the appropriate error number.
SEE ALSO cpr(7), nodev(9F)
Writing Device Drivers
SunOS 5.10 9 Oct 2001 dump(9E)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)