netbsd man page for clr

Query: clr

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

SET(9)							   BSD Kernel Developer's Manual						    SET(9)

NAME
SET -- primitive bit macros
SYNOPSIS
#include <sys/types.h> void SET(val, x); void ISSET(val, x); void CLR(val, x);
DESCRIPTION
These macros define three standard bit-operations: 1. SET() sets the bit x in val; 2. CLR() clears the bit x in val; and 3. ISSET() returns 1 if the bit x is set in val.
SEE ALSO
bits(3)
BUGS
The rationale is to provide clarity in the source code, but arguably these operations are clear enough without the use of the macros.
BSD
April 13, 2010 BSD
Related Man Pages
__shiftout(3) - netbsd
__shiftin(3) - netbsd
bits(3) - netbsd
sccs-val(1) - redhat
sccs-val(1) - php
Similar Topics in the Unix Linux Community
clrs create error, sun cluster 3.2
Clear Screen Command for BASH shell
Reminder for qvdlgczqbclr: Spammed Advertisements
TCL scripting: errorInfo=integer value too large to represent