netbsd man page for bcmp

Query: bcmp

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BCMP(9) 						   BSD Kernel Developer's Manual						   BCMP(9)

NAME
bcmp -- compare byte string
SYNOPSIS
#include <sys/systm.h> int bcmp(const void *b1, const void *b2, size_t len);
DESCRIPTION
The bcmp() interface is obsolete. Do not add new code using it. It will soon be purged. Use memcmp(9) instead. (The bcmp() function is now a macro for memcmp(9).) The bcmp() function compares byte string b1 against byte string b2, returning zero if they are identical, non-zero otherwise. Both strings are assumed to be len bytes long. Zero-length strings are always identical. The strings may overlap.
SEE ALSO
memcmp(9)
BSD
July 7, 2001 BSD
Related Man Pages
bcmp(3) - linux
bcmp(3) - opendarwin
bcmp(3) - minix
bcmp(3) - x11r4
bcmp(3) - php
Similar Topics in the Unix Linux Community
Need help in building gcc on solaris.
Unix gurus : how to grep this pattern?
Explanation reqd for the Unix file
A script need help