netbsd man page for thread_exit

Query: thread_exit

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

THREAD_EXIT(9)                                             BSD Kernel Developer's Manual                                            THREAD_EXIT(9)

NAME
thread_exit -- abandon current thread context
SYNOPSIS
#include <sys/param.h> #include <sys/proc.h> void thread_exit(void);
DESCRIPTION
The thread_exit() function implements the machine independent prelude to a thread shutdown. It will not return, and will result in a call to mi_switch(9) to schedule some other thread. thread_exit() arranges to free all the resources of the thread, specifically the kernel stack. To protect the runqueue(9), thread_exit() must be called with the sched_lock mutex held.
SEE ALSO
mi_switch(9), mutex(9), runqueue(9), sleep(9) BSD July 5, 2002 BSD
Related Man Pages
cpu_switch(9) - freebsd
cpu_switch(9) - netbsd
mi_switch(9) - linux
mi_switch(9) - hpux
cpu_switch(9) - hpux
Similar Topics in the Unix Linux Community
FATAL:exception occured with pthread_exit()
leak memory when thread exit
Doubt on pthread_exit and pthread_join
pthread_exit and pthread_join usage
pthread_exit query