Query: setjmp
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
SETJMP(9) BSD Kernel Developer's Manual SETJMP(9)NAMEsetjmp, longjmp -- non-local jumpsSYNOPSIS#include <machine/types.h> #include <sys/systm.h> int setjmp(label_t *label); void longjmp(label_t *label);DESCRIPTIONThe setjmp() function saves its calling environment in label. It returns zero on success. The longjmp() function restores the environment saved by the most recent invocation of setjmp(). It returns so that kernel execution continues as if the corresponding invocation of the setjmp() had just returned. setjmp() and longjmp() are a machine-independent interface for machine-dependent implementations. These functions are primarily used by ddb(4).SEE ALSOddb(4)BSDMay 23, 2002 BSD
Related Man Pages |
---|
longjmp(3) - freebsd |
_longjmp(3) - mojave |
setjmp(3) - mojave |
_longjmp(3) - osx |
longjmperror(3) - osx |
Similar Topics in the Unix Linux Community |
---|
signal() and sigsetjmp() |