netbsd man page for set

Query: set

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

SET(9)							   BSD Kernel Developer's Manual						    SET(9)

NAME
SET -- primitive bit macros
SYNOPSIS
#include <sys/types.h> void SET(val, x); void ISSET(val, x); void CLR(val, x);
DESCRIPTION
These macros define three standard bit-operations: 1. SET() sets the bit x in val; 2. CLR() clears the bit x in val; and 3. ISSET() returns 1 if the bit x is set in val.
SEE ALSO
bits(3)
BUGS
The rationale is to provide clarity in the source code, but arguably these operations are clear enough without the use of the macros.
BSD
April 13, 2010 BSD
Related Man Pages
val(1) - sunos
__bits(3) - netbsd
bits(3) - netbsd
sccs-val(1) - sunos
sccs-val(1) - x11r4
Similar Topics in the Unix Linux Community
How to setup basic telnet?
Internet setup on solaris10
Setting printer paper length using unix commands
Keep only the closet match of timestamped row (include headers) from file1 to precede file2 row/s
SAS dataset to CSV