Query: optstr
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
OPTSTR(9) BSD Kernel Developer's Manual OPTSTR(9)NAMEoptstr_get -- Options string managementSYNOPSIS#include <sys/optstr.h> bool optstr_get(const char *optstr, const char *key, char *buf, size_t bufsize);DESCRIPTIONAn options string is a list of key/value pairs represented in textual form. Each pair is expressed as ''key=value'' and is separated from other pairs by one or more spaces. For example: key1=value1 key2=value2 key3=value3 Options strings are used to pass information between userland programs and the kernel in a binary-agnostic way. This makes them endianness and ABI independent.FUNCTIONSThe following functions are provided to manage options strings: optstr_get(optstr, key, buf, bufsize) Scans the optstr options string looking for the key key and stores its value in the buffer pointed to by buf copying a maximum of bufsize bytes. Returns 'true' if the key was found or 'false' otherwise, in which case buf is left unmodified.CODE REFERENCESThe options string management functions are implemented within the files sys/kern/subr_optstr.c and sys/sys/optstr.h.HISTORYOptions strings appeared in NetBSD 4.0.BSDAugust 11, 2007 BSD
Related Man Pages |
---|
prop_dictionary_get_cstring_nocopy(3) - netbsd |
prop_dictionary_get_cstring(3) - netbsd |
hash32_strn(9) - netbsd |
openpam_subst(3) - freebsd |
mousex::nativetraits::hashref(3pm) - debian |
Similar Topics in the Unix Linux Community |
---|
Script runs fine on UNIX Server...Not through MSK Tool kit on Windows Server |
parse long input parameters |
[BASH] Using getopts |
Question about getopts optional argument [args...] |