Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kdassert(9) [netbsd man page]

KASSERT(9)						   BSD Kernel Developer's Manual						KASSERT(9)

NAME
KASSERT, KASSERTMSG, KDASSERT, KDASSERTMSG -- kernel expression verification macros SYNOPSIS
void KASSERT(expression); void KASSERTMSG(expression, format, ...); void KDASSERT(expression); void KDASSERTMSG(expression, format, ...); DESCRIPTION
These machine independent assertion-checking macros cause a kernel panic(9) if the given expression evaluates to false. Two compile-time options(4) define the behavior of the checks. 1. The KASSERT() and KASSERTMSG() tests are included only in kernels compiled with the DIAGNOSTIC configuration option. In a kernel that does not have this configuration option, the macros are defined to be no-ops. 2. The KDASSERT() and KDASSERTMSG() tests are included only in kernels compiled with the DEBUG configuration option. The KDASSERT() and KASSERT() macros are identical except for the controlling option (DEBUG vs DIAGNOSTIC). Basically, KASSERT() should be used for light-weight checks and KDASSERT() should be used for heavier ones. Callers should not rely on the side effects of expression because, depending on the kernel compile options mentioned above, expression might not be evaluated at all. The panic message will display the style of assertion (debugging vs. diagnostic), the expression that failed and the filename, and line num- ber the failure happened on. The KASSERTMSG() and KDASSERTMSG() macros append to the panic(9) format string the message specified by format and its subsequent arguments, similar to printf(9) functions. SEE ALSO
config(1), options(4), CTASSERT(9), panic(9), printf(9) AUTHORS
These macros were written by Chris G. Demetriou <cgd@netbsd.org>. BSD
September 27, 2011 BSD

Check Out this Related Man Page

ASSERT(3)                                                    Linux Programmer's Manual                                                   ASSERT(3)

NAME
assert - abort the program if assertion is false SYNOPSIS
#include <assert.h> void assert(scalar expression); DESCRIPTION
This macro can help programmers find bugs in their programs, or handle exceptional cases via a crash that will produce limited debugging output. If expression is false (i.e., compares equal to zero), assert() prints an error message to standard error and terminates the program by calling abort(3). The error message includes the name of the file and function containing the assert() call, the source code line number of the call, and the text of the argument; something like: prog: some_file.c:16: some_func: Assertion `val == 0' failed. If the macro NDEBUG is defined at the moment <assert.h> was last included, the macro assert() generates no code, and hence does nothing at all. It is not recommended to define NDEBUG if using assert() to detect error conditions since the software may behave non-deterministi- cally. RETURN VALUE
No value is returned. ATTRIBUTES
For an explanation of the terms used in this section, see attributes(7). +----------+---------------+---------+ |Interface | Attribute | Value | +----------+---------------+---------+ |assert() | Thread safety | MT-Safe | +----------+---------------+---------+ CONFORMING TO
POSIX.1-2001, POSIX.1-2008, C89, C99. In C89, expression is required to be of type int and undefined behavior results if it is not, but in C99 it may have any scalar type. BUGS
assert() is implemented as a macro; if the expression tested has side-effects, program behavior will be different depending on whether NDE- BUG is defined. This may create Heisenbugs which go away when debugging is turned on. SEE ALSO
abort(3), assert_perror(3), exit(3) COLOPHON
This page is part of release 4.15 of the Linux man-pages project. A description of the project, information about reporting bugs, and the latest version of this page, can be found at https://www.kernel.org/doc/man-pages/. GNU 2017-09-15 ASSERT(3)
Man Page